[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: stretch not booting

Thanks for your continued help!

On Thu, May 18, 2017 at 6:46 AM, Brian <ad44@cityscape.co.uk> wrote:

GRUB does its job but it appears the problem occurs when control is
handed over to the init system.

At the GRUB menu edit the linux line to add systemd.unit=rescue.target
or systemd.unit=emergency.target.

systemd.unit=rescue.target gets stuck (just as before).

systemd.unit=emergency.target boots!  I can log in as root, but journalctl -xb gives nothing.  (And I don't know what else I can do then.  The system is read-only...)

You might get to a terminal to look at what the journalctl command and
/var/log/syslog reveal.

I tried a few of the grub commands in there, such as

  systemd.log_level=debug systemd.log_target=console console=ttyS0,38400


systemd.journald.forward_to_console=1 console=ttyS0,38400

but no new messages seem to go to the boot screen.

I also tried


but either tty9 looks exactly the same as the one from boot, or it is not switching.

Any suggestions would be appreciated...

Reply to: