[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SOLVED] Re: mouse cursor disappeared after upgrading from wheezy to jessie (xfce 4)

Unistalling the proprietary fglrx driver for Radeon worked. I just reinstall the xserver-xorg-video-ati and it's working.

The reason why I had the proprietary driver is that the radeon GPU would increase the heat to 85-90 celsius and drain a lot of battery lfie (seems to be ok with Jessie).

2015-05-01 18:27 GMT-03:00 Rafael Dias da Silva <rafael.dias.silva@gmail.com>:
Well, that would be another chapter of my long battle to fix my discrete card.
I have an integrated intel device and a discrete radeon 700 series.

I'll try uninstalling the proprietary drivers to settle with the open source alternative (if it works I can even turn the radeon off with KMS and stick to the integrated intel gpu).

Thanks for the heads-up.

2015-05-01 16:40 GMT-03:00 Francisco M Neto <fmneto@gmail.com>:

What is your GPU?

I ran into something very similar when using the discrete GPU on a hybrid setup. If I use the integrated GPU the mouse pointer is there, but when using the discrete GPU it disappears, although the cursor *is* there just as effective as before; I just can't see it.

From what I could gather this is an X.Org issue; perhaps your problem is related. I'm not at my computer right now but I can provide some links later.


On May 1, 2015 10:47 AM, "Rafael Dias da Silva" <rafael.dias.silva@gmail.com> wrote:

I tried that too. I even installed oxygencursors in order to have more cursors to change to LOL.
I also tried stopping and even uninstalling gnome-settings-daemon (someone did it and it solved the issue for xfce, but that was on ubuntu) and I'm still stuck with this annoying problem.

On May 1, 2015 4:03 AM, "Petter Adsen" <petter@synth.no> wrote:
On Fri, 1 May 2015 08:59:40 +0200
Petter Adsen <petter@synth.no> wrote:

> On Fri, 1 May 2015 00:37:00 -0300
> Rafael Dias da Silva <rafael.dias.silva@gmail.com> wrote:
> > I tried a few more tips I found but nothing brings back the cursor.
> >
> > I have no idea what Jessie might have done to make it disappear (it
> > was working just fine after upgrade and before dist-upgrade).
> What DE/WM are you using? I had this problem with Enlightenment when I
> enabled "Gnome services on startup".

Sorry. Didn't see the "xfce" part. Can you try switching mouse cursor


"I'm ionized"
"Are you sure?"
"I'm positive."

Rafael Dias da Silva
"Il n'y a qu'une tristesse, celle de n'être pas des saints."
- Léon Bloy

Rafael Dias da Silva
"Il n'y a qu'une tristesse, celle de n'être pas des saints."
- Léon Bloy

Reply to: