[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: boot-time messages, /init touch not found

The Wanderer wrote:
>songbird wrote:
>> The Wanderer wrote:
>>> songbird wrote:
>>>> /boot/initrd.img-3.18.0-trunk-686-pae: ASCII cpio archive (SVR4 with
>>>> no CRC)
>>> So it's not compressed at all.
>>> Try
>>> cpio -i < /boot/initrd.img-3.18.0-trunk-686-pae
>>> to expand it (again, from within an _empty_ directory).
>>   yes, that did not give an error.  but not much is in
>> there:  this is interesting...  :)
>> # cpio -i -v < /boot/initrd.img-3.18.0-trunk-686-pae
>> kernel
>> kernel/x86
>> kernel/x86/microcode
>> kernel/x86/microcode/GenuineIntel.bin
>> 22 blocks
>> # du .
>> du .
>> 16	./kernel/x86/microcode
>> 20	./kernel/x86
>> 24	./kernel
>> 28	.
> That's _very_ weird. If my experience is any guide, there should be an
> entire root-like hierarchy in there; mine contains
> bin/ conf/ etc/ init lib/ lib64/ run/ sbin/ scripts/
> with appropriate content under each. Instead, this looks like a simple
> "addon filesystem" archive.
> Unless there's an entire angle here which I'm missing, there would
> appear to be something badly wrong with your initramfs-generating
> configuration. Unless this initramfs isn't actually used at all, I'm
> frankly surprised your system even boots with that configuration.

  surely i'm not an expert in the early boot or
the initramfs setup.  but i'm glad you've confirmed
it looks strange.  it does boot.

  i tried a different setup on a different partition which
has older initramfs's:

gunzip - < /alt/boot/initrd.img-3.16.0-4-686-pae | cpio -i
69075 blocks

  and when i look at the directory there is what you would
expect to be there.

  so at least i know that worked before.  it's been some time
since i've updated those (mid February).

> Unfortunately, I don't have enough experience in the initramfs area to
> tell out what that "something wrong" might be, or how to repair it. I
> could probably figure it out with access to the affected system in order
> to experiment, but I don't have that access and I don't expect to get it
> at this remove.
> I hope someone else will be able to step in and carry this further. Good
> luck!

  thanks for your responses.  :)


Reply to: