[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian 7 and external monitors and graphics adaptors

Quoting Bret Busby (bret.busby@gmail.com):
> On 17/04/2015, Liam O'Toole <liam.p.otoole@gmail.com> wrote:
> > On 2015-04-16, Bret Busby <bret.busby@gmail.com> wrote:
> >> On 17/04/2015, Ric Moore <wayward4now@gmail.com> wrote:
> >
> > <SNIP>
> >
> >>> Have you tried "catalyst" for the AMD setup?? Under AMD Mobility
> >>> Product Family your 6000 series is listed.
> >>> http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst14-9LINReleaseNotes.aspx
> >>>
> >>
> >> Hello.
> >>
> >> I assume something bad is in the source code of that web page (it is
> >> aspx, so, proprietary MS stuff), but, with two web browsers - Arora
> >> and rekonq, running on Debian 6, I can only see a bit at the op of the
> >> web page - no scroll bar or any way to get to the important stuff
> >> lower down on the web page.
> >>
> >> Publishing a web page about Linux stuff, in MS only format, is a bit
> >> weird.
> >>
> >> It is kind of like the manuafacturer (AMD) wants to hide its Linux
> >> stuff, from Linux users.
> >
> > It is nothing of the sort. The site Works fine in iceweasel on jessie.
> > It should work on wheezy, which has the same version of iceweasel, too.
> >
> > Any browser you run in squeeze was EOL'ed years ago, from a security
> > perspective if nothing else.
> >
> What it comes down to, has nothing to do with the version number of Debian.

I don't think that was Liam's point. You said you were running a
squeeze browser, 21 lines above and again 6 lines below this one.
That would be a security risk were it not LTS.

> What it came down to, is, the web page bien aspx shite, it requires
> javascript (javashite).
> I installed a 12.x version of opera (from my Debian 6 desktop system),
> on this (Debian 7, running on the Acer E5-521-238Q) system,  and left
> javascript enabled, and the web page works.
> In going to the Ubuntu 14.04 64 bit option, as such packages are
> usually .deb packages, and so, tend to work on Debian (which is how I
> got Seamonkey installed and working on this system, from an old
> version of Seamonkey.deb, that I had obtained), I downloaded and tried
> to install the package.

I'm not sure I can tell what package you mean here.

> I got a dependency problem;
> "Error: Dependency is not satisfiable: fglrx-core"
> So, I seached in Synaptic, for fglrx, and found
> fglrx-driver;

But that isn't fglrx-core is it? Don't you need something like

> "
> non-free ATI/AMD RadeonHD display driver
> FGLRX / AMD Catalyst is the non-free proprietary display driver for the
> ATI/AMD RadeonHD and FireGL graphics cards. As an alternative, you may try
> the newest free driver xserver-xorg-video-radeon.
> This driver release supports the following graphics adapter families:
> AMD Radeon HD 7000, AMD Radeon HD 6000, and AMD Radeon HD 5000.
> "
> So, I searched within Synaptic, for xserver-xorg-video-radeon .
> I found that xserver-xorg-video-ati and xserver-xorg-video-radeon, are
> already installed.

I take it that's on your wheezy system.

> The first has, in its package description;
> "
> X.Org X server -- AMD/ATI display driver wrapper
> This package provides the 'ati' driver for the AMD/ATI Mach64, Rage128,
> Radeon, FireGL, FireMV, FirePro and FireStream series. This driver is
> actually a wrapper that loads one of the 'mach64', 'r128' or 'radeon'
> sub-drivers depending on the hardware.
> These sub-drivers are brought through package dependencies.
> Users of Rage, Mach, or Radeon boards may remove this package only if
> they use Driver "r128", "mach64", or "radeon" in /etc/X11/xorg.conf
> instead of relying on autodetection.
> "
> and, for the secomd;
> "
> X.Org X server -- AMD/ATI Radeon display driver
> This package provides the 'radeon' driver for the AMD/ATI cards. The
> following chips should be supported: R100, RV100, RS100, RV200, RS200,
> RS250, R200, RV250, RV280, RS300, RS350, RS400/RS480, R300, R350, R360,
> RV350, RV360, RV370, RV380, RV410, R420, R423/R430, R480/R481,
> RV505/RV515/RV516/RV550, R520, RV530/RV560, RV570/R580,
> RS600/RS690/RS740, R600, RV610/RV630, RV620/RV635, RV670, RS780/RS880,
> "
> So, for Debian 7, two driver packages for AMD/ATI Radeon video things,
> were already installed, but, they, apparently, do not cover the
> applicable video controller.

But we were expecting that weren't we? I thought the problem was that
you have this nice new hardware.

> And, the manufacturer's driver, apparently, can not be installed, due to
> "Error: Dependency is not satisfiable: fglrx-core"
> The Synaptic list of packages, returned in searching for fglrx, does
> not include the unsatisfiable dependency package; fglrx-core.

I don't know what synaptic is. Are you searching the Debian wheezy
archives? Might it be worth trying with jessie (I can't remember if
you said you'd tried this).


Reply to: