[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian 8 jessie long running sudo and X login

Hi community,
After upgrade to jessie I had one more strange experience.
For some reason krb5-user was installed and I remember asking me about
windows domain authentication. As I use this computer at work as well I
said yes (there is domain which I could use to authenticate). However
before I get there I have work to do, but I noticed that when I login to
the local machine it took something like 1min. Same when I run sudo. I was
thinking this could be a hostname resolution or alike, but the machine is
checking the hostname from the hosts file first, so negative.
I could find the rootcause by running strace -p (sudo pid).
It turned out it was quering a kerberos.mit.edu server, which is
unreachable. Looking further it truned out that this is in
the /etc/krb5.conf file, which is part of the krb5-user.
However this package was removed, but the conf file was left over. I tried
to reproduce it - apt-get install and dpkg --purge /etc/krb5.conf is there.
Do you thing it is a bug or a feature? In my opinion it is a bug.


Reply to: