[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

VPN routing on Sid

I'm having problems connecting to my desktop (running actually
aptosid, which is virtually simply Debian Sid with a different kernel
and a few extra tools and customizations).

Here is the situation: my desktop is connected to a VPN service.  (The
router to which the desktop is connected is not, only the desktop.
So, the VPN client runs on the desktop and the other computers on the
network connect to the Internet directly.)

When I first started using the VPN service, I could not SSH to my
desktop from outside the network anymore.  After a lot of googling, I
found out a solution (https://forums.openvpn.net/topic7163-15.htm):
I've added the following script to /etc/network/if-up.d:


ip rule add from table 10
ip route add default via table 10

where is the IP of the desktop and is the
IP of the router.

That worked perfectly and until recently.  (I'm sorry I cannot be more
precise about when, but I'd say within the last 30 days or so it
stopped working.)  I could connect to the desktop from anywhere.  But
recently, when I run the script above (as I've been doing for a
while), I can still connect from *outside* my network, but *not* from
inside (i.e., other computers connected to the same router).  From
within the network, nothing works (SSH, Samba, minidlna...).  As soon
as remove the rules (with "ip rule/route del ..."), I can connect
again from inside (but, of course, not from outside anymore).

I'd appreciate any comments or suggestions.  (The desktop is up to
date with Sid repositories, by the way.)



Reply to: