[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dropbox install break apt-get



On Sat, 23 Aug 2014, tom arnall wrote:

> I tried to install dropbox and the result is that apt-get is broken.
> (I do not by the way want dropbox on my system and want to purge it
> completely.)

A few stupid questions, first:

How did you initially try to install dropbox?

   apt-get install nautilus-dropbox, or
   apt-get install dropbox?  Then install the nautilus-dropbox
   extension?

Did you set up a Dropbox account before the install?  Or at all?

Since it's apparent that the initial installed failed (for whatever
reasons), you're not going to be able to "remove" or "purge" it as
you've found out.  I would do an apt-get clean as well as an
autoremove, then use the --fix-broken option to try to complete the
install.  And if that works, then purge it.

Have you tried the --reinstall option?  Or --force?

You might try downloading the .deb file from Dropbox, install it, then
purge

> Here is the output which demonstrates the current state of the system:
> 
> [snip]
> 
> i find btw reports of this problem going back to 2012. why is debian
> allowing the thing in the repository?

Could be a GNOME or nautilus-dropbox extension problem instead.  Dropbox
installed and runs fine on my Wheezy 64-bit system, BUT....  I don't run
the GNOME desktop and don't use nautilus.  I have just a window manager,
Openbox, and a single LXPanel for my GUI.  Also, I downloaded the .deb
file directly from Dropbox and installed it.  It set up Dropbox's own
Debian Repository that I get updates from.  My current Dropbox version
is 2.10.27.  I use the Xfe file manager.  Dropbox works fine with it.

B


Reply to: