[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Jessie early boot failure: "/sbin/init exists but couldn't execute it (error -8)" (initrd corrupt?)

Am 2014-07-26 17:10, schrieb Brian:
I would appreciate any hints!

A d-i image such as the netinst one has a rescue mode which could help
in any repairs to your machine.

Thanks for the hint. I never realized how capable rescue mode is.

But now I'm even more confused.

Whatever I try, I alway end up with an early kernel panic "Kernel panic - not syncing: No working init found.".

I've built new initrd images with mkinitrd. Same error.

I've exchanged systemd-sysv and backrolled to sysvinit and have again built new images. I have verified that I booted with the new initrd and that the new initrd contained the sysvinit. Same error on boot again.

I reinstalled systemd-sysv, replaced initramfs-tools with dracut, and built new images with dracut. Verified that I was indeed using the new images. Same error on boot again.

I tried different kernels. Same error. Only that the error message is less specific on 3.2.0 than with 3.1.14: The later always says "(error -8)".

Obviously the error 8 is for ENOEXEC - Exec format error. I wonder what this could mean. The kernel is i386 (686-pae) and /sbin/init is as well i386.

I'm still looking forward to hints how to recover from this problem ;-)

Best regards,

Reply to: