[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Jessie early boot failure: "/sbin/init exists but couldn't execute it (error -8)" (initrd corrupt?)

My system is running a mix of stable/testing. I managed to upgrade to systemd, which brought a whole bunch of problems, boot still booted nevertheless.

But now, somehow, the system is stuck in the very early boot process: After just 1,5s the system stalls with this error:

Failed to execute /init (error -8)
Starting /init: /sbin/init exists but couldn't execute it (error -8)
Starting /init: /bin/sh exists but couldn't execute it (error -8)
Kernel panic - not syncing: No working init found. Try passing init= option to kernel. See Linux Documentation/init.txt for guidance.
Call Trace:
... ? dump_stack
... ? panic...
... ? kernel_init...
... ? ret_from_kernel_thread...
... ? rest_init...
Kernel Offset: 0x0 from 0xc1000000 (relocation range: 0xc0000000-0xf81fdfff)

This is with the stock 3.14-1-686-pae from testing, which worked well the days before. I have an old 3.2.0 on board, but it fails with an similar error.

Then, I have a very old 2.6.32 from oldstable, which get further, starts systemd, seems to switch over to the root fs, but then gets stuck somehow after 10s.

Now I wonder how I could start the system.

I upgraded initramfs-tools shortly before this problem happended (although I think the a reboot still worked after that), so I guess it might be a problem with the new initrd.img-3.14-1-686-pae file.

But how to recover from that?

At the moment I'm lost how to boot the system again.

I already extracted the initramfs from a rescue CD, but the contents seem reasonable. /sbin/init is there, /bin/sh is there, and all seems well.

I also tried to add "break=init" to the command line, but it had no effect at all.

Also, specifying a different init ("init=/sbin/init.sysvinit") had no effect at all.

Am I right that these options have no effect during the initrd.img phase?

I would be glad if somebody could give me a few hints where to start with this problem.

I would appreciate any hints!


Reply to: