[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't install Debian - USB keyboard doesn't turn on until Windows loads

That was a good idea. I tried it, but the keyboard still did not work.

I believe this is the correct motherboard:


There is a barcode sticker on the mobo with that number on it.

I only got the computer when I bought it. No manual, keyboard, etc. came with it.

I was digging around the online documentation trying to figure out where the reset jumper was located and found this:


This is also strange to me. On some mobo's they tell you to swap the jumper to the other pin which resets the CMOS then switch it back before you power it on because it can damage the board. With this board, you swap the jumper and then turn it on and you wind up in CMOS when it boots. However, my keyboard was still not working while in CMOS.

So, I unplugged everything and took out the battery. Waited a while, then plugged everything back in but I left the battery out. Then powered it on. I wound up back in CMOS again and the keyboard still did not work. So, I unplugged everything again and put the battery back in.

I think it did reset CMOS though. Because now it says that there was a battery failure and that there is a CMOS checksum error and something about the time being not set. I also unplugged my hard drive and it tried to boot off the network. So, it seems to work OK. It still boots the hard drive when it is plugged in.

After all my poking and prodding, I am thinking that maybe it needs a certain type of USB keyboard in order to have a working keyboard at boot. I know that some USB devices have to have drivers before the computer knows what to do with them. I'm thinking that may be the case with my keyboard but not sure. Maybe the mobo simply does not power up the USB ports at boot. But then that doesn't really make any sense either.

This is the strangest computer that I have worked with.

On Sat, Jun 28, 2014 at 1:56 AM, Tom Furie <tom@furie.org.uk> wrote:
On Sat, Jun 28, 2014 at 01:39:45AM -0600, Kitty Cat wrote:

> I'm thinking that a previous owner turned off the legacy USB keyboard
> support in the CMOS and since there is no option for a PS/2 keyboard, I
> think it may be stuck without keyboard access at boot time.

If you can find a manual for the motherboard there should be a jumper to
clear CMOS which will reset the BIOS settings to defaults.
Alternatively, removing the CMOS battery for a few seconds will usually
achieve the same result. I would imagine that USB keyboard support would
be enabled in the default settings.


<Knghtbrd> hardcopy is for wussies
<Topher> computer program listings....next, on HardCopy

Reply to: