[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

gnome3 mouse issues?

I've been running gnome3 on wheezy for about a month now. I've noticed
that gnome3 will periodically (several times an hour) seem to stop
responding but doesn't completely freeze. When this happens I can move
the mouse and keyboard works in already open windows but mouse clicks
do not register in any application nor can I even click builtin parts
of the shell like the clock or pull up the activities bar. Somehow
after alt+tabbing and clicking around it will eventually come back to
normal but I am unable to find a specific pattern I am doing that
restores things to normal. I think most likely after some time thing
happens behind the scenes that brings it back to life.

I tried several simple things just to rule them out:
- made sure my wheezy was update to (im current as of the time of this email)
- upgraded kernel to 3.8.10 (built from source, works fine but no
change in behavoir)
- switched back from nvidia's binary gfx driver back to nouveau
- tried plugging in several external mice instead of using my builtin touchpad

Googling the issue can be frustrating because it comes up with lots of
vague results but the one query that seems to be relevant was "gnome 3
mouse click". This comes back with quite a few forums for various
distros which include gnome3 and many people seem to be describing
similar behavoir to what I am seeing.

After going through all the things listed above, as of a few hours ago
just for giggles I installed KDE (not thrilled about it though) and
have not seen the issue at all.

This makes me think it is unlikely a hardware issue nor any kernel
issue, and simply a gnome only issue.

The part that puzzles me is that I've been a member of debian-user for
several years and havent really seen any signifcant noise on the list
thats resembles my issue.

I am running a dell m4500 with i7 @ 2.8ghz, 16gb ram, nvidia quadro fx 1800M
current kernel is 3.8.10 (from source), prior kernel from wheezy was

Anyone seen anything like this? Any ideas how to troubleshoot further?
It's a shame because I was actually really liking gnome3 but this is a
major annoyance that hinders productivity.

Thanks in advance

Reply to: