[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: huawei e169 +asterisk

On 04/16/2013 02:54 PM, Tom Grace wrote:
On 16/04/13 12:12, binary dreamer wrote:
Sorry, my mistake. i forgot to mention the errors:

root@debPBX:/usr/src/dongle-read-only# automake -a
configure.in:6: installing `./config.guess'
configure.in:6: installing `./config.sub'
configure.in:7: installing `./install-sh'
configure.in:7: installing `./missing'
automake: no `Makefile.am' found for any configure output

Did you try from a tarball, rather than SVN ? You might have an easier
time with that.

this is the output after the tarball extraction.
root@debPBX:/usr/src/chan_dongle-1.1.r14# make
gcc -g -O2 -O6 -I.  -D_GNU_SOURCE -I/usr/include -I/usr/include -DHAVE_CONFIG_H  -fvisibility=hidden -fPIC -Wall -Wextra -MD -MT app.o -MF .app.o.d -MP  -o app.o -c app.c
In file included from app.c:21:
/usr/include/asterisk/version.h:1:2: error: #error "Do not include 'asterisk/version.h'; use 'asterisk/ast_version.h' instead."
app.c: In function ‘app_status_exec’:
app.c:37: warning: missing initializer
app.c:37: warning: (near initialization for ‘args.resource’)
app.c: In function ‘app_send_sms_exec’:
app.c:82: warning: missing initializer
app.c:82: warning: (near initialization for ‘args.device’)
app.c: In function ‘app_register’:
app.c:162: warning: passing argument 2 of ‘ast_register_application2’ from incompatible pointer type
/usr/include/asterisk/module.h:458: note: expected ‘int (*)(struct ast_channel *, const char *)’ but argument is of type ‘int (*)(struct ast_channel *, void *)’
make: *** [app.o] Error 1

i have tried all versions from r10 to r14 and i am getting the same problem.

i have tried all the versions from

Reply to: