[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Mac Mini EFI issues

Hello all,

I've been installing wheezy on a Mini for most of the afternoon/evening, and I'm nearly there.  The first issue with the install was that grub-pc is installed by default, so I had to manually purge it and install grub-efi before reboot.  grub-efi installation was also highly manual and still not complete.

Second problem was that that partman set the partition type to EF00 on the root filesystem…  So nothing could see it.  I manually changed it to 8300 (using gdisk), not sure if that was correct or not, but it has at least let the Mac side see it as something other than Free Space.  However, Fuse-ext2 still doesn't see it, so perhaps the partition tag is still wrong.

I'm at the point now that grub-efi gives me a command prompt (when EFI loaded from holding down the option key, aka Apple Boot Selector or something), with zero configuration.  Got that covered, except the kernel won't load due to not finding the root filesystem (root=/dev/sdb3 not working).  I'm about to try UUID next.  Course, I had to boot off CD again to find the UUID...

rEFInd still doesn't see the bootable Linux partition.  But that's out of scope of this mailing list.

So my question is: should setting this up have been so difficult?  Or is it just not optimized for an Intel Mac and they are inherently problematic?  Or did I do things wrong?

I am trying to avoid a hybrid partition table, as there will be no Windows on this (well, not directly).  My actual goal is to run this Debian install as Xen dom0 and migrate the existing MacOS X into a domU plus add windows as well.  But that's a later step.

Any suggestions appreciated!  Thanks,


Reply to: