[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SD card formatting problem

> On Saturday 17 November 2012 10:36:07 you wrote:

>> I have a 32GB sd card that I have been trying to use as a transfer
>> disk for a 19GB file.

If you must interface with Window$, you should look at the Debian
package ntfs-3g; there is a manual page and a wiki

As an experiment:

(1) I used a laptop running Window$7 to reformat a new (FAT32) 32Gbyte
SDHC; I used the laptop because it had an internal SD slot.  In the
format dialogue, I gave the device a label (SDHC-NTFS), and I
UNchecked the "quick format" box.  It appears that a "full format" is
necessary if the file system is being changed from FAT or FAT32 to
NTFS.  The formatting process took a half hour or longer; thankfully,
M$ included a progress bar.

(2) I plugged the newly-formatted SDHC into a SIIG "USB Multi Card
Reader" (USB2) and then I plugged the cable of the reader into a USB
socket (USB2) on a desktop running Debian Squeeze.  In a few seconds,
a "File Browser" (Nautilus 2.30.1) window opened, displaying the
(empty) contents of the SDHC device.  With the command "/cat/etc/mtab"
I discovered that the SDHC was mounted at "/media/SDHC-NTFS".

(3) Using the "dd" command, I created on the hard drive of the desktop
an ISO image from a software installation DVD.

(4) I used "rsync" to copy the ISO image from the hard drive to the
SDHC card.

(5) I plugged the SDHC card into the SD slot of the W$7 laptop, but
W$7 was unable to access the card; instead, W$7 requested permission
to format the card.

(6) I returned to the Debian desktop machine and used "mkfs.ntfs" to
reformat the SDHC card.

(7) I repeated step #4.

(8) I repeated step #5, with the same result.

(9) I then removed the SDHC card from the W$7 laptop, plugged the card
into a card reader (this time, a SIIG "USB 3.0 Multi Card Reader"),
which happened to be at hand, and I used the "Disk Utility 2.30.1" to
verify that the file system of the card still was "clean".

(10) I then plugged the cable of the same card reader into a USB port
of the W$7 laptop.  The card was recognized immediately, and the ISO
image was displayed by Window$ Explorer.

(11) As a final check, I then plugged the SDHC card into the SIIG USB2
card reader, and plugged the cable of the reader into the W$7 laptop.
Again, the ISO image was displayed by Window$ Explorer.

I do not understand why the internal card reader of the W$7 laptop
was unable to read the card.  A reader which I purchased years ago
worked with SD but not with SDHC; however, the internal reader of the
W$7 laptop is able to read FAT32 SDHC cards.


Reply to: