[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: startup: separate /var partition hoses /run, shm (shared memory)?




On Fri, Nov 16, 2012 at 2:47 PM, Tom Roche <Tom_Roche@pobox.com> wrote:

What must one do to make /run mount appropriately on startup if one has
a separate /var partition? What I mean, why I ask:

Awhile ago, I got a new box with win7 preinstalled. I repartitioned,
adding separate partitions for swap, /, /boot, /home, /tmp, /usr, /var
(in addition to the win7 partition). I then installed LMDE (Linux Mint
Debian Edition, a directly-debian-derived, rolling-release, APT-packaged
distro). This has worked well, except for a problem at startup, whether
after restart (i.e., warm boot) or shutdown (i.e., cold boot):

On every startup, on the initial {black screen, white text} I get errors
beginning with

> Mount point '/run' does not exist. Skipping mount.

and ending (just before it goes to X) with many (10 > n > 100) lines
beginning with

> shm_open() failed

I suspect this is related to having a separate /var partition, since,
once the box is booted and I'm logged in, I see that

* /run is symlinked to /var/run
Since /run is meant to replace all temporary filesystems in RAM I would expect this to be other way around, ie /var/run to be symlinked to /run. So /run should be a tmpfs and /run/shm and /run/lock part of it. Also /dev/shm should ne symlinked to /run/shm as well. Can you post your /etc/fstab and output from 'df -hl' command?
 
* /run/shm is a directory

I'm wondering, how to fix this problem? E.g., can I make /var (and
therefore /var/run) mount before whatever is trying to mount /run?

If there is a better place to ask this question, please lemme know.

TIA, Tom Roche <Tom_Roche@pobox.com>


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 87y5i2i4zj.fsf@pobox.com" target="_blank">http://lists.debian.org/87y5i2i4zj.fsf@pobox.com



Reply to: