[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: CPU scaling problems



>>>>>  Francesco wrote:

I have installed Debian testing on a X1 Carbon, processor i5-3427U.

My problem is the following: when the `ondemand' governor is active, the
processor clock never scales up, it always stays at 800Mhz.  The situation
changes when using the `conservative' or the `performance' governors.  More
curiously, if I set `conservative'/`performance' as the governor for at
least one core, the CPU will scale.  I am on the 3.6.6-trunk-amd64 kernel
from experimental because the intel video driver 3.2 causes random freezes.
To test if the scaling occurs I run `stress -c 4'.

Things I have tried:

* Enabling/disabling `cpufreqd', `laptop-mode', and `acpid'.  I currently
run
  `laptop-mode'.
* The 3.2 kernel in testing
* Enabling/disabling the `xfce4-power-manager', which I use to manage
  suspends/hibernate.

There are some kind-of relevant BIOS options and I will try with those soon
but I doubt that's the issue.

Does anybody have any idea on how to troubleshoot such a problem?  I suspect
that the problem is either in the kernel or in some other software which is
regulating the scaling.
<<<<<


At a guess, I would assume a configuration problem.  Or no problem.  Is your
machine sluggish or unresponsive?  How do you know it stays at 800 MHz?
What tool do you use to monitor it?  Maybe your monitor is wrong.  I am not
sure how to troubleshoot this, but if you don't need the governor, turn it
off or use the 'performance' one.  

If you solve the problem, let us know the solution, it may be useful to
others.

Good luck!




Reply to: