[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

CPU scaling problems


I have installed Debian testing on a X1 Carbon, processor i5-3427U.

My problem is the following: when the `ondemand' governor is active, the
processor clock never scales up, it always stays at 800Mhz.  The situation
changes when using the `conservative' or the `performance' governors.  More
curiously, if I set `conservative'/`performance' as the governor for at least
one core, the CPU will scale.  I am on the 3.6.6-trunk-amd64 kernel from
experimental because the intel video driver 3.2 causes random freezes.  To test
if the scaling occurs I run `stress -c 4'.

Things I have tried:

* Enabling/disabling `cpufreqd', `laptop-mode', and `acpid'.  I currently run
* The 3.2 kernel in testing
* Enabling/disabling the `xfce4-power-manager', which I use to manage

There are some kind-of relevant BIOS options and I will try with those soon but
I doubt that's the issue.

Does anybody have any idea on how to troubleshoot such a problem?  I suspect
that the problem is either in the kernel or in some other software which is
regulating the scaling.


Reply to: