[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

BD-RE mount problem

I've been using BD-RE discs for backups on a Debian/Squeeze server for a couple of years now. In the last week or so the backups have been failing. I haven't modified my backup script so I thought about possible hardware issues.

- I tried changing the BluRay writer but got the same problem.
- I tried new discs but got the same problem.
- I tried replacing the PCI-SATA controller that the machine needed for the BluRay writer, but still got the same problem. - the discs do formate correctly when I try dvd+rw-format -force=full /dev/sr0

Finally, I tried an entirely different machine with a different model of BluRay writer and I'm still getting the same problem.

This new machine has a different architecture (AMD64) and is running Debian/Wheezy. Why am I getting the same problem?

I tried a new disc again, and this time formatted it through K3B instead of using dvd+rw-format directly. It appeared to format correctly - and no longer shows as an empty BD-RE disc when I insert it - but still wouldn't mount.

All the mount attempts give exactly the same result:

  # mount /media/dvd
  mount: block device /dev/sr0 is write-protected, mounting read-only
  mount: wrong fs type, bad option, bad superblock on /dev/sr0,
         missing codepage or helper program, or other error
         In some cases useful info is found in syslog - try
         dmesg | tail  or so

The /etc/fstab entry is the same between the two machines:
  /dev/sr0        /media/dvd      udf     user       0       0

I'm using Memorex BD-RE 2x discs. I've used an LG, ASUS and Pioneer BluRay writer - the first two on the older machine. The ASUS and Pioneer are brand new writers.

Any ideas?

Reply to: