[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem updating debian 6



> I solved my recent problem with aptitude (and apt) by installing bzip2 package. Until then I was getting rather ridiculous error messages from aptitude, which in no way indicated that absence of bzip2 was the problem. Just FYI.

The bzip2 package was installed before the problems start.

2012/5/23 Chris Bannister <cbannister@slingshot.co.nz>:
> On Wed, May 23, 2012 at 09:20:55AM +0200, David Seira wrote:
>> Yes. I have another servers with the same configuration in another places.
>>
>> > Under  "/var/lib/apt/lists/" is where the index files are kept.
>> > What I'd do is delete those:
>> > i.e. "rm /var/lib/apt/lists/*" then do apt-get update again.
>> >
>> > Then worry about the GPG warnings after.
>> >
>>
>> I remove the index files in the directory you said but the result is the same:
>
> This is getting weirder and weirder.
>

Yes, is the only server I manage that has this problems.

> There are some other things you can try, but if they don't work or
> something else strange happens as a consequence you could bugger up your
> package management system, and I don't want to be responsible for that.
>
> i.e. under /var/lib/dpkg/available.
> man dpkg
>
> E.g see:
> http://ubuntuforums.org/showthread.php?t=1752868
>

Reading this post it seems it could be a network problem. The problem
is that I don't manage the network, only the server.

>
> What does "ls -al /var/lib/apt/lists/" show now?
>

-rw-r--r-- 1 root root 31488757 may 18 00:56
ftp.es.debian.org_debian_dists_squeeze_main_binary-amd64_Packages
-rw-r--r-- 1 root root  1964287 may 18 00:56
ftp.es.debian.org_debian_dists_squeeze_main_i18n_Translation-es
-rw-r--r-- 1 root root 18362177 may 18 00:56
ftp.es.debian.org_debian_dists_squeeze_main_source_Sources
-rw-r--r-- 1 root root   110865 may 18 00:56
ftp.es.debian.org_debian_dists_squeeze_Release
-rw-r--r-- 1 root root     1672 may 18 00:56
ftp.es.debian.org_debian_dists_squeeze_Release.gpg
-rw-r--r-- 1 root root    59231 may 18 00:56
ftp.es.debian.org_debian_dists_squeeze-updates_main_binary-amd64_Packages
-rw-r--r-- 1 root root     2161 may 18 00:56
ftp.es.debian.org_debian_dists_squeeze-updates_main_binary-amd64_Packages.IndexDiff
-rw-r--r-- 1 root root    14864 abr 17 11:14
ftp.es.debian.org_debian_dists_squeeze-updates_main_source_Sources
-rw-r--r-- 1 root root     2161 may 18 00:56
ftp.es.debian.org_debian_dists_squeeze-updates_main_source_Sources.IndexDiff
-rw-r--r-- 1 root root   113464 may 18 00:56
ftp.es.debian.org_debian_dists_squeeze-updates_Release
-rw-r--r-- 1 root root      836 may 18 00:56
ftp.es.debian.org_debian_dists_squeeze-updates_Release.gpg
-rw-r----- 1 root root        0 abr 17 11:12 lock
drwxr-xr-x 2 root root     4096 may 24 07:33 partial
-rw-r--r-- 1 root root  1261300 may 17 23:58
security.debian.org_dists_squeeze_updates_main_binary-amd64_Packages
-rw-r--r-- 1 root root   309643 may 17 23:58
security.debian.org_dists_squeeze_updates_main_source_Sources
-rw-r--r-- 1 root root    86939 may 17 23:58
security.debian.org_dists_squeeze_updates_Release
-rw-r--r-- 1 root root      836 may 17 23:58
security.debian.org_dists_squeeze_updates_Release.gpg

> Can you spare another server for testing purposes?
>

No. As I told you before, this is the only server with strange behaviour.

> Do the same on another server, with exactly the same sources list.
>

All the servers that I manage have the same sources list and haven't
any problem with it.

> You're sure you haven't changed anything on this server recently, i.e.
> before this problem started happening? Even if it seems totally
> unrelated. E.g, on Google someone had a problem similar to this when
> they changed the language (probably locales)
>

Yes. I'm 100% sure that I don't change anything :-). This server is
used for a radius server.

>> Err http://security.debian.org squeeze/updates/main amd64 Packages
>>   Sub-process /bin/bzip2 returned an error code (2)
>> Fetched 13.7 kB in 1s (7933 B/s)
>

Is strange this message. I' ve managed several debian server for
several years and I never found this error.

> Mmmm,
> I'd expect to see something like:
> Hit http://security.debian.org squeeze/updates InRelease
>
>> W: Failed to fetch
>> http://ftp.es.debian.org/debian/dists/squeeze/main/source/Sources.bz2
>> Sub-process /bin/bzip2 returned an error code (2)
>> W: Failed to fetch
>> http://ftp.es.debian.org/debian/dists/squeeze/main/binary-amd64/Packages.bz2
>>  Sub-process /bin/bzip2 returned an error code (2)
>> W: Failed to fetch
>> http://ftp.es.debian.org/debian/dists/squeeze-updates/main/source/Sources.bz2
>>  Sub-process /bin/bzip2 returned an error code (2)
>> W: Failed to fetch
>> http://ftp.es.debian.org/debian/dists/squeeze-updates/main/binary-amd64/Packages.bz2
>>  Sub-process /bin/bzip2 returned an error code (2)
>> W: Failed to fetch
>> http://security.debian.org/dists/squeeze/updates/main/source/Sources.bz2
>>  Sub-process /bin/bzip2 returned an error code (2)
>> W: Failed to fetch
>> http://security.debian.org/dists/squeeze/updates/main/binary-amd64/Packages.bz2
>>  Sub-process /bin/bzip2 returned an error code (2)
>
>> E: Some index files failed to download, they have been ignored, or old
>> ones used instead.
>
> Just for testing, comment out all entries in your sources list, except
> for
> deb http://security.debian.org/ squeeze/updates main
> (it cleans the screen for easier reading.)
>

Yes, I tried this yesterday evening but the results were the same.

> what does:
> cat /etc/apt/sources.list
> show?
>
> what does:
> apt-get update
> show?
>
> I want to see **all** the output please, even if you have to use
> typescript.
>

This is the sources.list with only the security repository enabled:

root@radius:/etc/apt# cat sources.list
#

# deb cdrom:[Debian GNU/Linux 6.0.2.1 _Squeeze_ - Official amd64
NETINST Binary-1 20110628-12:58]/ squeeze main
#deb cdrom:[Debian GNU/Linux 6.0.2.1 _Squeeze_ - Official amd64
NETINST Binary-1 20110628-12:58]/ squeeze main

#deb http://ftp.es.debian.org/debian/ squeeze main
#deb-src http://ftp.es.debian.org/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main
#deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
#deb http://ftp.es.debian.org/debian/ squeeze-updates main
#deb-src http://ftp.es.debian.org/debian/ squeeze-updates main

And this is the apt-get update output with the modified sources.list:

root@radius:/etc/apt# apt-get update
Get:1 http://security.debian.org squeeze/updates Release.gpg [912 B]
Get:2 http://security.debian.org/ squeeze/updates/main Translation-en [912 B]
99% [2 Translation-en bzip2 0 B] [Waiting for headers]bzip2: (stdin)
is not a bzip2 file.
Ign http://security.debian.org/ squeeze/updates/main Translation-en
Get:3 http://security.debian.org/ squeeze/updates/main Translation-es [912 B]
66% [3 Translation-es bzip2 0 B] [Connecting to security.debian.org
(149.20.20.6)]bzip2: (stdin) is not a bzip2 file.
Ign http://security.debian.org/ squeeze/updates/main Translation-es
Get:4 http://security.debian.org squeeze/updates Release [912 B]
Err http://security.debian.org squeeze/updates Release

Fetched 3648 B in 2s (1812 B/s)
Reading package lists... Done
W: A error occurred during the signature verification. The repository
is not updated and the previous index files will be used. GPG error:
http://security.debian.org squeeze/updates Release: The following
signatures were invalid: NODATA 1 NODATA 2

W: Failed to fetch http://security.debian.org/dists/squeeze/updates/Release
W: Some index files failed to download, they have been ignored, or old
ones used instead.


>
> What does:
> ls -al /etc/apt/apt.conf.d/
> show?
>

root@radius:/etc/apt# ls -al /etc/apt/apt.conf.d/
total 28
drwxr-xr-x 2 root root 4096 Apr 17 11:36 .
drwxr-xr-x 6 root root 4096 May 24 07:40 ..
-rw-r--r-- 1 root root   81 Apr 17 11:12 00CDMountPoint
-rw-r--r-- 1 root root   40 Apr 17 11:12 00trustcdrom
-rw-r--r-- 1 root root  395 Apr 15  2011 01autoremove
-rw-r--r-- 1 root root  141 May 31  2011 20listchanges
-rw-r--r-- 1 root root  182 Jan 30  2011 70debconf

> Do you have an "/etc/apt/apt.conf" file? If yes paste the contents?
>

No, I haven't this file.

> You haven't got some sort of network/firewall problem have you?
> It may not be a package problem at all, bit I'd expect 404 errors, etc.
>

The internet connection works correctly because I manage this server
remotely. I don't know if the firewall has a special rule that blocks
this type of traffic.

> I'm starting to run out of ideas.
>

Yes, me too.

I have two theories. First, it could be a network/firewall problem
despite the server has connectivity. Second, it could be a signature
problem because in all of the messages mentions "A error occurred
during the signature verification".

Another cheat I could try is to download the packages from another
server and install locally with dpkg. What do you think about this?

I don't know, I'll continue trying.

>
>
> --
> "If you're not careful, the newspapers will have you hating the people
> who are being oppressed, and loving the people who are doing the
> oppressing." --- Malcolm X
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: 20120523172836.GC2523@tal">http://lists.debian.org/20120523172836.GC2523@tal
>


Reply to: