[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RAID1 does not boot



Thanks, i found out the problem but still i am confused actually
i have disk 1 and disk 2  with same specs like they both are 320 GB
and same made. here is my partition flow
(because i had tried installation so many times so i change the
partition structure)

1. /Boot 1GB (Boot on and on RAID /dev/md0)
2. SWAP 4 GB (RAID /dev/md1)
3, / (remaining space) (RAID /dev/md2)

now at the end after installation when system rebooted for the first
time i receive "error loading operating system" actually in BIOS boot
option i mistakenly selected SATA2 as boot instead of SATA 1. when i
shift things back i manage to reach grub menu.

now the part where i am confuse is that i believed that the computer
should have booted from SATA2 as well  because boot partition is also
installed over it too. as i have created /boot partiton on RAID which
was md0. now for instance if my SATA 1 goes down then i would be
handicap as it will not going to boot from SATA2.
 please suggest me what should i do in this regard. because what i
want that, if some thing happen to any of the drive i just have to
unplug the bad one and replace it with the new one ofcourse i know i
have to make same RAID partition and stuff but what i want is if SATA1
Fails i want SATA 2 to boot with out any complex efforts.

Thanks






On Thu, Apr 5, 2012 at 4:37 PM, Camaleón <noelamac@gmail.com> wrote:
> On Thu, 05 Apr 2012 14:43:40 +0500, Muhammad Yousuf Khan wrote:
>
>> i am a newbie, i tried RAID 1 installation on VM which was working fine.
>> now i tried to install the same scenario on physical machine. i have two
>> 300 GB Hard drives and i want to make a RAID1 every things work
>> perfectly. i created the RAID partition and then RAID device. i created
>> 3 partition on the RAID drive.
>>
>> 1./boot (1GB)
>> 2.SWAP (not on RAID)
>> 3./Root (300 GB)
>>
>> now everything when fine to the end of the installation but the problem
>> is when i restart the machine after installation. it doest boot however
>> in VM machine it didn't happen.
>
> A virtual machine does not always helps to diagnose hardware related
> issues and the VM can be using a different set of kernel modules for the
> disks.
>
> Anyway, what error are you getting when booting? Can you reach the GRUB's
> menu?
>
>> but one thing i notice during
>> installation it is giving me the message "the Kernel was unable to
>> re-read the partition table on /dev/md0 (invalid argument) this means
>> Linux won't know anything about the modifications you made until you
>> reboot you should reboot you computer before doing anyting with
>> /dev/md0.
>>
>>  i tried Squeez 6.0.4 and
>> Lenny  several times and at the end  no-success.
>
> There are similar installation errors reported here:
>
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507653
>
> But that shouldn't have additional drawbacks other than the warning.
>
> My guess is that the problem here is booting from the raid volume.
>
> Greetings,
>
> --
> Camaleón
>
>
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: [🔎] jlk05q$mrm$4@dough.gmane.org">http://lists.debian.org/[🔎] jlk05q$mrm$4@dough.gmane.org
>


Reply to: