[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RAID1 does not boot

On Thu, 05 Apr 2012 14:43:40 +0500, Muhammad Yousuf Khan wrote:

> i am a newbie, i tried RAID 1 installation on VM which was working fine.
> now i tried to install the same scenario on physical machine. i have two
> 300 GB Hard drives and i want to make a RAID1 every things work
> perfectly. i created the RAID partition and then RAID device. i created
> 3 partition on the RAID drive.
> 1./boot (1GB)
> 2.SWAP (not on RAID)
> 3./Root (300 GB)
> now everything when fine to the end of the installation but the problem
> is when i restart the machine after installation. it doest boot however
> in VM machine it didn't happen. 

A virtual machine does not always helps to diagnose hardware related 
issues and the VM can be using a different set of kernel modules for the 

Anyway, what error are you getting when booting? Can you reach the GRUB's 

> but one thing i notice during
> installation it is giving me the message "the Kernel was unable to
> re-read the partition table on /dev/md0 (invalid argument) this means
> Linux won't know anything about the modifications you made until you
> reboot you should reboot you computer before doing anyting with
> /dev/md0.
>  i tried Squeez 6.0.4 and
> Lenny  several times and at the end  no-success.

There are similar installation errors reported here:


But that shouldn't have additional drawbacks other than the warning.

My guess is that the problem here is booting from the raid volume.



Reply to: