[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get will upgrade aptitude will not

On Mon, 19 Mar 2012 14:17:44 +0000, Bonno Bloksma wrote:

> To answer most questions asked:


Would have been better to reply to every message separately...

> 3)
> The last time I ran a full-upgrade was when I upgraded from Lenny. I
> think this system started out as an Etch system years ago. I'd like to
> think the aptitude full-upgrade (or apt-get dist-upgrade) is only to be
> used when doing major upgrades. But.... ~# aptitude full-upgrade
> The following packages will be upgraded:
>   mysql-common
> 1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> Need to get 69.6 kB of archives. After unpacking 57.3 kB will be freed.
> Do you want to continue? [Y/n/?]n

So "full-upgrade" worked. Curious.

> 5)
> Aptitude upgrade with the -v (or -vv or -vvv) switch gives not much more
> info, just: Current status: 0 broken [+0], 1 update [+0], 16431 new
> [+0].

There is "one" update available. Next time you can open aptitude and 
manually browse the available package to gather more information on why 
is not going to be updated.

> So it seems the update is present on my system and ready to be
> installed, just not by a normal aptitude upgrade. It is either a normal
> apt-get upgrade or an aptitude full-upgrade. But why.....?
> I will just do an apt-get upgrade now.

There must be a good reason (and I bet this deserves a full reading¹), 
but I never use aptitude unless apt-get goes crazy and wants to do weird 
things :-)




Reply to: