[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Seerious problems after NetworkManager upgrade - WAS: Re: Problem with NetworkManager

Selim T. Erdogan wrote:
Bernard,  5.03.2012:
Tom H wrote:

[Stuff deleted]
Sounds like when you turn off wicd, then ifup and ifdown work the way you want them to.
Yes. But this is not the way I wanted it, since this PC is supposed to be used by a number of persons who may not be at ease in opening an Xterm, switching to superuser with the appropriate password and then typing 'ifdown eth0' 'ifup...' every time they wish to connect or disconnect. With the old Lenny system - before I upgraded - they easily connected and disconnected doing a right click on the NetworkManager icon on the gnome desk.

So, since I had so little success with the NM and Wicd programs that I had on my system, I first removed the 'Wicd' and 'Wicd-daemon' packages and then tried to see if a newer version of NetworkManager was available :

#apt-get install -s network-manager

showed that it was a matter of replacing a huge number of packages by newer ones, including gnome packages etc... After a short hesitation, I decided to go ahead.

#apt-get install network-manager

did a thourough job !!! At one time, it warned that : "The nm applet could not find some needed resources ; it cannot continue...". I clicked on the OK, and the process nevertheless continued up to the end.

Then I re-booted.

The newly installed network manager (yes, it did install despite the warnings that the applet could not continue) seems to work better then the old one. It does operate connecting and disconnecting upon clicking in the right place.

But my system now behaves in a weird way !

At first, it is.... very very slow ! 5 to 10 full seconds to wait an xterm to open after clicking to the icon that is supposed to open it ; same thing with any program.

The program 'top' shows that 90% of my CPU is used by "mutter", which is supposedly a kind of desk manager... 10% of the CPU is taken by Xorg, only a fraction of one percent is free to other applications !!!

I very briefly read the man page of mutter, and tried to shut it down:

#mutter --replace

Then the system got a lot more speed... except that a lot of functions were now unavailable: I can't drag and drop xterms, I can't go from one desk to another....

Thanks in advance for your help in restoring a convenient desktop environment

Reply to: