[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

OT? - Debian on eeePC? boot fails

Asus eeepc

A friend brought it to me to see if I could update Firefox & Flash.

I started by using the built-in software update tool, but that didn't give me much joy. I finally figured out how to get into a terminal window, and I did an aptitude update and aptitude dist-upgrade. Had some failures; apparently Asus doesn't keep their repositories up-to-date with themselves.

After a reboot, it tries to start the gui (looks like the mouse cursor for a non-window-managed X, and occasionally the gray background of same), but then it drops back to a black screen, and cycles this way infinitely. Sometimes I can see a message at the top of the screen that says:

udevd[909]: add_to_rules: unknown key 'PRODUCT', in 'ACTION'

(at least, that's what I think it says; it only flashes on for a half-second at a time)

By googling for the past day, I've figured out how to get into a busybox terminal (by adding XANDROSBOOTDEBUG=y to the end of the kernel line by editing the grub prompt), but that doesn't give me much.

Googling more allowed me to get a bit farther by mounting sda1 and sda2 on mnt-system and mnt-user respectively.

I've tried getting into various run-levels by adding 1 or 3, etc, to the end of the kernel line; I've tried running things like "init 1", but it says init is not found; I've tried putting an "exit 0" line early on in the rc2.d/S99kdm script.

But none of this stuff works; I don't know if the eeepc is using some customized version of Debian causing it to bypass all my efforts, or if the udev error is getting in the way (I know almost nothing about udev stuff).

If anyone knows enough about udev stuff to get me fixed, or if anyone knows specifics about the Debian on eeepc's that would get me farther along, I'd appreciate it.


Kent West<*)))><
Praise Yah! \o/

Reply to: