[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: issue with mdadm and mirroring drives

>> My configuration is as such:
>> /dev/md0 = /dev/sdc1 and /dev/sdd1
>> /dev/md1 = /dev/sda1 and /dev/sb1
>> ****My swap partitions are not part of the array or mirror  at all -
>> they are just regular partitions - they are:
>> /dev/sdc2 and /dev/sdd2.
> Any particular reason do do that ? If you want your system/applications
> to carry on working if a disk fails you need the swap on raid1 too.

I see your point - I will create new linux raid auto partitions and
mirror it as well - thanks
>> When I boot the system with all drives in, I get the superflous error.
>> So the only way to boot is only to put in /dev/sdc alone and boot.
>> when i get to a linux prompt, I insert the second drive into the system /dev/sdd
>> To sync them, /dev/sdd has already failed, so i run
>> sfdisk -d /dev/sdc | sfdisk /dev/sdd
>> ** i get an error that nothing has changed - so I run it with the
>> --force command to get the partitions identical like:
>> sfdisk -d /dev/sdc | sfdisk --force /dev/sdd
> Why do you do that ? You are forcing the partitioning of the first disk
> onto the second, this could work at raid creation time but isn't the
> proper procedure to re-add a failed member to an array. You don't have
> to "sync" the data and even less the disk partitioning manually prior to
> re-adding it to the raid. mdadm will handle the resync.

I did not mean to do this - i think this is my main issue - i can not
zero out drives with mdadm.
It gives an error that i can not get past - so i use force option.

Do you recommend any other utility to zero out drives - that will make
them blank ?
I think it maybe an issue with my working drive - i think the
partitions are screwed up there - and when sfdsik copies - it does not
copy correctly.
But i did boot with knoppix and went to fdisk and deleted the
partitions - but still had issues with sfdisk.
An utilty u recommend ??

>> Model: ATA ST31000340AS (scsi)
>> Disk /dev/sdc: 1000GB
>> Sector size (logical/physical): 512B/512B
>> Partition Table: msdos
>> Number  Start   End     Size    Type     File system     Flags
>>  1      1049kB  996GB   996GB   primary  ext3            raid
>>  2      996GB   1000GB  4204MB  primary  linux-swap(v1)
>> Model: ATA ST31000528AS (scsi)
>> Disk /dev/sdd: 1000GB
>> Sector size (logical/physical): 512B/512B
>> Partition Table: msdos
>> Number  Start   End     Size    Type     File system     Flags
>>  1      1049kB  996GB   996GB   primary  ext4            raid
>>  2      996GB   1000GB  4204MB  primary  linux-swap(v1)
> Why do you have file-systems on your partitions ? Only the "md" raid
> devices should be formatted with a file-system, not the underlying
> partitions !
> I would be curious to know what "fsck" says about your md devices (fsck
> /dev/md0 for example) ?

Again - i think sfdisk copy from working drive is causing this issue.
Can i go into fdsik to fix ?
Change the labels ? i just think they are labeled incorrectly.

> I am starting to think that you have much lower level problems. When you
> created this system, where the disks "clean", or did you use "sfdisk"
> over existing formatted partitions ? Where the disks used in a raid
> before ? If this is the case you should consider backing up and
> recreating the raid properly.
> Also, if one disk is repeatedly dropping from the raid array, consider
> looking at the "smart" values, it may be dying.

What smart values are u refering to ? is that a utility ?
Again - i think i need a clean utility or at least a procedure other
then --zero option of mdadm to clear out the drive.


Reply to: