[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: (Solved) Re: Wheezy: "module unix not found in modules.dep"

Camaleón wrote:
On Fri, 06 Jan 2012 19:19:49 +0000, Brian wrote:

On Fri 06 Jan 2012 at 17:08:46 +0000, Camaleón wrote:

Since one of the latest kernel upgrades I started seeing this message
when booting:

"module unix not found in modules.dep"


There are no side effects, all works fine but what's missing and how to
to get rid of it?
Comment out the line 'force_load unix' in /initramfs-tools/hooks/udev
and run

   update-initramfs -u

Yup, that worked like a charm, thanks :-)

(the file is located under "/usr/share/initramfs-tools/hooks/udev")

Personally I wouldn't bother. As you say, it does no harm and when in
time it disappears you will know the bug is gone.

Agree. For that reason I did the changes on a virtualized wheezy and left "as is" my netbook which also runs wheezy. Let's monitor how time it takes to solve this ;-)

(and sorry for the delay in replying, I had to deal with a semi-broken VM wheezy system after I updated a gibibyte of data. Wow, how bad is not doing regular updates... thanks aptitude I could recover the system nicely)

A little off the topic of your mail (and rhetorical) I wonder what your
reaction will be when testing gets the new sysvinit?

What "new sysvinit"? You mean "systemd"? :-?

I've only read about problems and headaches coming from users and admins for systemd which is currently the default init system for another distributions so let's see how Debian handles this. My first impression is that distributions made the transtition too soon... these things need time to:

a) Get users and admins accustomed to the new system

b) Solving the highest number of problems/bugs before it reaches the streets

c) Write down detailed documentation for users migrating from sysvinit and newcomers

That package (systemd) is in Sid. What determines that it must be used? Deactivation of sysv-rc?


Reply to: