[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Reboot and all I get is a grub prompt.

On Mon, Dec 5, 2011 at 10:06 AM, Brian <ad44@cityscape.co.uk> wrote:
> On Mon 05 Dec 2011 at 08:44:51 -0600, Harry Putnam wrote:
>> When I run update-grub, it appears to be working but ends with
>> something akin to an error:
>>   root # update-grub
>>   Generating grub.cfg ...
>>   Found background image:
>>   /usr/share/images/desktop-base/desktop-grub.png
>>   Found linux image: /boot/vmlinuz-3.0.0-1-686-pae
>>   Found initrd image: /boot/initrd.img-3.0.0-1-686-pae
>>   Cannot find list of partitions!  (Try mounting /sys.)
>>   done
>> So its not clear if it has finished properly or what.
> OSs on other partitions will not be found.
>> Apparently /sys is not populated in a chroot, or there is something I
>> needed to run before chroot.
> mount -o bind /sys <mount_point>/sys

I only bind-mount "/dev"; for "/sys", I run:
mount -t sysfs sysfs /path_to_mountpoint/sys

Reply to: