[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: setting up WiFi adapter (Broadcom BCM4321 14e4:4328 chipset) in latest version of Debian

Following all of your suggestions, here is what I've been able to discover:

My laptop is HP Touchsmart tx2-1025dx (AMD Turion x2 64 cpu), and
there is an LED on front for the wireless,
which turns green when it is enabled/active (in Windows OS at least). It has
never come on in Debian yet (stays orange = disabled)

lspci shows:
08:00.0 Network controller: Broadcom Corporation BCM4321 802.11a/b/g/n (rev 03)

after a fresh reboot,
lsmod does not show anything I can find loading related to wifi or broadcom...
 (what does this mean, or what should I be looking for)?

After issuing 'modprobe b43' I get:
root@HPTx2:/home/colinrei# lsmod | grep b43
b43                   146204  0
rng_core                3006  1 b43
mac80211              137372  1 b43
cfg80211              101496  2 b43,mac80211
led_class               2433  1 b43
ssb                    38698  1 b43
mmc_core               45702  2 b43,ssb
pcmcia                 19474  2 b43,ssb
pcmcia_core            24118  3 b43,ssb,pcmcia

based on what I can discern from the broadcom wifi driver info website,
my pci wifi-chipset should be supported by the 'b43' driver module.

dmesg shows:
[    1.002837] b43-pci-bridge 0000:08:00.0: PCI INT A -> GSI 17
(level, low) -> IRQ 17
[    1.002837] b43-pci-bridge 0000:08:00.0: setting latency timer to 64
[ 6168.059496] b43-pci-bridge 0000:08:00.0: PCI INT A disabled
[ 6169.212655] b43-pci-bridge 0000:08:00.0: restoring config space at
offset 0x1 (was 0x100002, writing 0x100006)
[ 6230.544133] b43-pci-bridge 0000:08:00.0: PCI INT A -> GSI 17
(level, low) -> IRQ 17

Also, just installed the 'lshw' package and it shows me this:

            description: PCI bridge
            product: RS780 PCI to PCI bridge (PCIE port 1)
            vendor: Advanced Micro Devices [AMD]
            physical id: 5
            bus info: pci@0000:00:05.0
            version: 00
            width: 32 bits
            clock: 33MHz
            capabilities: pci pm pciexpress msi ht normal_decode
bus_master cap_list
            configuration: driver=pcieport
            resources: irq:25 memory:d1200000-d12fffff
               description: Network controller
               product: BCM4321 802.11a/b/g/n
               vendor: Broadcom Corporation
               physical id: 0
               bus info: pci@0000:08:00.0
               version: 03
               width: 64 bits
               clock: 33MHz
               capabilities: pm msi pciexpress bus_master cap_list
               configuration: driver=b43-pci-bridge latency=0
               resources: irq:17 memory:d1200000-d1203fff

ifconfig -a (as root) shows:
 entries for: eth0, lo, pan0.  Nothing else...?

Using the Wicd network manager applet in Gnome shows:
 wired network connected,
 no wireless networks found

I also tried adding pci=assign-busses to the kernel command line at
startup, but that doesnt seem to have done it either.

So... can anyone see the problem? Suggestions or next steps to
troubleshoot? Thank you,


On Sat, Dec 3, 2011 at 4:26 AM, Camaleón <noelamac@gmail.com> wrote:
> On Thu, 01 Dec 2011 12:07:24 -0800, Colin Reinhardt wrote:
>> Im new to Debian/Linux...
> Okay, then better if you tell what's the version you are running
> (squeeze, testing or sid) :-)
>> I have tried following the Debian Wireless-HowTo and other related Linux
>> WiFi HowTos.
>> I downloaded and installed the firmware-b43-installer and b43-fwcutter,
>> (synaptic shows them as installed packages now).
> Did you also load the kernel module? "lsmod | grep b43" will tell.
>> In Gnome, using network-manager (applet) there is nothing about wireless
>> networks shown at all, only my wired LAN ethernet network is an option.
>> How can I tell if my PCI card is being detected
> It has been detected because you know what's the chipset device ID ;-)
> To be sure run "lspci | grep -i broadcom"
>> and firmware loaded correctly,
> I already told you.
>> and what are the next steps to get WiFi working?
> If you have followed all of the required steps, there are no errors at
> dmesg and still the card is not detected by NM you can:
> a) Report it at Debian BTS
> b) Try with another wireless driver that supports your device (wl).
> Greetings,
> --
> Camaleón
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: [🔎] pan.2011.">http://lists.debian.org/[🔎] pan.2011.

Reply to: