[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kdesud locking up, JMicron card reader not working, USB 3 Controller stops working after resuming, horizontal tearing on fullscreen

> >>> 2) The laptop has a JMicron card reader that only works if the card is
> >>> inserted at boot time.
> >>
> >>Mmm... what's dmesg output when you connect a card? Is it detected/
> >>mounted?
> >>
> > NO dmesg output. Not detected, not mounted, not anything.
> That's weird. You mean that when you insert a card, once the computer has
> booted, there is no system reaction at all? Have you tried with different
> media types (SD, MMC, Memory Stick...)? Are you putting the card in the
> right position (upside down or face up)? I ask this because some embedded
> card readers have the wire contacts at the top and others at the
> bottom :-)

I suppose, your jMicron Cardreader needs a kernel module. Check (without card) 
if it is loaded. If not, reboot with an inserted card, and check the 
difference. Loaded kernelmoduels are shown with the command "lsmod".

If in second case, the module ios loaded, and in first case not, try the 
following two solutiuons:

1. add the module in /etc/modules, reboot and try again.

if it does not help, then 

2. build an own kernel and add the required module into the kernel (not as a 
modul, build it directly into it), reboot, start the new kernel and try again.

3. Check your kernel version, I suggest to use 3.0

> >>> 4) This happens with all video applications on KDE, VLC, mplayer, etc.
> >>> When playing in fullscreen, both machines (with Nvidia graphics cards
> >>> and the driver from Nvidia), with compositing or not, with opengl
> >>> backend or not, vsync enabled or not, any video shows horizontal
> >>> tearing.
> >>
> >>For this one I would start debugging a driver issue by loading "nouveau"
> >>instead "nvidia". If both drivers experience the same it can be
> >>something pointing to Xorg :-?
> >>
> > The last time I tried to install nouveau, it tried to remove all nvidia
> > packages, and after that, it didn't work - black screen, no output, no
> > X, no console. I'll try again, but I reported this to the kde bug
> > tracking, and they're also trying to figure it out. So far, no luck.
> Use a Debian LiveCD, it will load "Nouveau" drivers and you can test if
> the same happens from here without needing to mess your current running
> system by switching between the two VGA drivers.

I suggest, not to use latest xserver-xorg for Nvidia-cards, there is a bug in 
the latest version, but it appears only at special graphic chips (GF8600 for 
example), try to use version 1.10.XXX.

Good luck!


Reply to: