[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kdesud locking up, JMicron card reader not working, USB 3 Controller stops working after resuming, horizontal tearing on fullscreen

On Sat, 05 Nov 2011 21:28:48 -0200, M. wrote:

> Hello Camaleón, hello list,
> I had to search for this post on the interwebs, as I'm not subscribed.
> But finally a good soul answered me! Thanks, Camaleón! :-)

You're welcome :-)

I know you're not subscribed to this list (me neither) but you can still 
reply to the thread you opened instead posting a new message. I say this 
because this new message is now unthreaded, with bad quoting -I will try 
to manually correct this- and with not further references so I have to 
search your first posting to remember the topic...

>>> So here it goes:
>>> 1) I use KDE 4.6, the latest version from unstable, and synaptic to
>>> install packages. synaptic needs sudo permissions, and KDE does that
>>> using kdesud. The problem is that sometimes the kdesud process hangs,
>>> and every other call to kdesud gets stalled. I have to go to the
>>> terminal and kill it by hand - after doing that, synaptic and any 
>>> other process that calls kdesud works fine. This happens on ALL debian
>>> unstable installations, both desktop and laptop.
>>Is that happening regardless of the command you run with "kdesu" or just
>>when you launch Synaptic?
> The only program that I' aware that's running kdesud is synaptic, so I
> dunno.

You can invoke "kdesu" (or "kdesudo") to run whatever program you want 
with root's permissions, not just Synaptic ;-). Kdesu is like "su" (or 
"sudo") but aimed to run GUI based applications.

So, if you run "kdesu kwrite" it will ask for root's password and then 
will launch kwrite as root ("man kdesu" if you are interested in this 

Note: if you run "kdesudo kwrite" it will ask for your user's password 
instead the root's one, as long as sudo has been properly configured in 
your system.

>>> 2) The laptop has a JMicron card reader that only works if the card is
>>> inserted at boot time.
>>Mmm... what's dmesg output when you connect a card? Is it detected/
> NO dmesg output. Not detected, not mounted, not anything.

That's weird. You mean that when you insert a card, once the computer has 
booted, there is no system reaction at all? Have you tried with different 
media types (SD, MMC, Memory Stick...)? Are you putting the card in the 
right position (upside down or face up)? I ask this because some embedded 
card readers have the wire contacts at the top and others at the 
bottom :-)

>>> 3) The USB 3 controller on the laptop never worked correctly. It is
>>> USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev
>>> 03) USB controller: Intel Corporation 5 Series/3400 Series Chipset 
>>> USB2 Enhanced Host Controller (rev 06)
>>> The two USB 3 ports never worked correctly: they disconnect or never
>>> connect usb peripherals, giving xhci_hcd errors like
>>> [ 6135.109318] xhci_hcd 0000:05:00.0: WARN: short transfer on control
>>> ep [ 6135.112271] xhci_hcd 0000:05:00.0: WARN: short transfer on
>>> control ep [ 6135.115274] xhci_hcd 0000:05:00.0: WARN: short transfer
>>> on control ep
> (...)
>>I have commented in another thread about a similar problem:
> I've blacklisted xhci_hcd, and so far the controller hasn't acted up.
> But this gonna take longer to test.

If the USB ports are behaving okay regardless the above error you don't 
need to worry. I have read that these are harmless kernel messages that 
should go away in the next kernel releases.

But if you were having problems with your USB 3.0 devices, this is 
something worth to report. Blacklisting the USB 3.0 module is a by-pass 
more than a real solution.
>>> 4) This happens with all video applications on KDE, VLC, mplayer, etc.
>>> When playing in fullscreen, both machines (with Nvidia graphics cards
>>> and the driver from Nvidia), with compositing or not, with opengl
>>> backend or not, vsync enabled or not, any video shows horizontal
>>> tearing.
>>For this one I would start debugging a driver issue by loading "nouveau"
>>instead "nvidia". If both drivers experience the same it can be
>>something pointing to Xorg :-?
> The last time I tried to install nouveau, it tried to remove all nvidia
> packages, and after that, it didn't work - black screen, no output, no
> X, no console. I'll try again, but I reported this to the kde bug
> tracking, and they're also trying to figure it out. So far, no luck.

Use a Debian LiveCD, it will load "Nouveau" drivers and you can test if 
the same happens from here without needing to mess your current running 
system by switching between the two VGA drivers.
>>> Please CC me as I'm not subscribed to the list.
>> Sorry, I can't :-(
> I had to search this on a weird forum, but at least I found it. Why you
> can't CC me?

Because my newsreader does not provide such option :-(



Reply to: