[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Permission Problem with xsane - more



On Fri, Oct 07, 2011 at 10:37:04AM +1100, Scott Ferguson wrote:
> On 06/10/11 01:38, Thomas H. George wrote:
> > On Wed, Oct 05, 2011 at 08:57:59AM -0400, Alan Greenberger wrote:
> >> On 2011-10-03, Thomas H. George <lists@tomgeorge.info> wrote:
> >>  (...)
> >>>>>> Tell us your scanner model? :-)
> >>>>>>
> >>>>> Epson Perfection 2400 Photo
> >>>>
> >>>>
> >>  (...)
> >>> Just found the following:
> >>>
> >>>
> >>> Script started on Mon 03 Oct 2011 03:38:15 PM EDT
> >>> tom@dragon:~$ lsusb -s 001:005
> >>> Bus 001 Device 005: ID 04b8:011b Seiko Epson Corp. Perfection 2400 Photo
> >>> tom@dragon:~$ scanimage -L
> >>> device `epson2:libusb:001:005' is a Epson GT-9300 flatbed scanner
> >>> device `epson:libusb:001:005' is a Epson GT-9300 flatbed scanner
> 
> Alan's post has broken the thread - but in a previous post I mentioned
> that "The problem seems to be that *both* epson and epson2 backends are
> being called"
> 
> <snipped>
> >> $ grep epson /etc/sane.d/dll.conf
> > epson
> > epson2
> 
> This is where epson *and* epson2 are *both* being called.
> Comment one of them out.
> The default on Squeeze is for *only* the epson2 backend to be active.
> 
I did comment out epson in dll.conf.  This did not solve the problem.
> What was the result of trying the suggested scanimage commands? (in the
> post you didn't respond to)
> 
> Cheers
> 
> 
I did respond to Alan's post repeating all his commands and finding no
difference in the file permissions.  I don't know why that response
didn't appear in this thread.

As a result of Alan's post I concluded the problem was with sane.  I
posted my results of Alan's tests to the sane-devel list and learned the
permission problem is a known sane problem.  Still, after trying all
sane instructions my permission problem was not solved.

I gave up.

I switched to trying to install the Epson iscan software.  The package
for Squeeze would not install as it required libltdl3 which existed in
Lenny but was replaced by libltd7 in Squeeze. Cameleon (my keyboard has
no circumflex for the o) pointed out that the version of iscan provided
for Ubuntu used libltd7 so I installed this version and it worked.

The segfault problem with xsane and xscanimage still exists but with
iscan installed the command xscan is now unknown.

My ultimate objective of running the scanner from gimp is only partially
achieved.  Gimp will run the scanner with xsane (xscanimage is greyed
out) and writes a default.pnm file but does open this image and leaves
the scanner hanging (scanner light flashing, scanner must be powered
down and up to be reset).

Note this behavior is different than executing the sane command from an
xwindow terminal.  In this case the segfault occurs before the scanner
is run.

I guess my problem is now a setup problem with gimp as there is a
message that a file cannot be opened.

In conclusion many thanks to all for trying to solve the segfault
problem.  It still is unresolved but iscan provides control of the
scanner.

Tom
> -- 
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: 4E8E3BA0.3050306@gmail.com">http://lists.debian.org/4E8E3BA0.3050306@gmail.com
> 
> 


Reply to: