[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB-Printer prints RAW PCL6-Code

On Mon, 05 Sep 2011 08:05:36 +0200, Martin Lorenz wrote:

>> Hum... it's weird that a problem with the USB stack allows windows to
>> print from the VM client because it finally ends at the same point.
>> I would review CUPS logs, just in case (/var/log/cups/*) and also try
>> with Samsug's linux unified drivers:
>> http://www.samsung.com/ca/support/detail/supportPrdDetail.do?menu=SP01&prd_ia_cd=&prd_mdl_cd=&prd_mdl_name=ML-2150
>> If none helps, I would open a bug report. If it worked fine with kernel
>> 2.6.39 (and same drivers) that can be something where to start looking
>> at.
> tried some more and found that it dosen't work with kernel 2.6.38
> either.
> When I spool several print-jobs in a row such that the second, third,
> etc. is in the queue before the first one has finished printing, than it
> spits out all jobs in a row fine and good.
> The moment i leave a pause for the printer to become idle between the
> first and second job the second one fails (and so do all subsequent
> jobs)

Next time go for a PostScript printer (or add this as add-in whether 
optional), you will avoid all these weirdnesses and won't be 
driver-dependant :-)
> and now another one: with a laptop running ubuntu 11.04 it works well.
> the laptop has older CUPS version, driver version and it does NOT
> blacklist usblp ...
> I meanwhile also tried to install Samsung's unified driver but with no
> luck. It dosen't even recognize the printer.
> So as a workaround I use the ubuntu laptop as print server while
> searching for a solution.

Opening a bug report will help to solve the issue quicker.



Reply to: