[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB-Printer prints RAW PCL6-Code

Hash: SHA1

Am 30.08.2011 23:52, schrieb Martin Lorenz:
> Am 30.08.2011 19:18, schrieb Matt Richardson:
>> On Tue, Aug 30, 2011 at 9:15 AM, Camaleón <noelamac@gmail.com> wrote:
>>> On Tue, 30 Aug 2011 17:45:43 +0200, Martin Lorenz wrote:
>>>> Again a rather strange behavior ...
>>>> My Samsung ML-2150, which is said to work perfectly with
>>>> cups/openprinting, did work well with my old computer.
>>>> Now with a new machine and a new system it only prints page after page
>>>> of RAW PLC6-Code whenever I try a second print-job after swithing it on.
>>>> The first job is printed flawlessly. From then on I might be lucky to
>>>> get a proper printout but most of the time I only receive garbage.
>>>> When I switch off the printer and on again the next job is good.
>>>> Any ideas where to start investigating? Is it a kernel issue?
>>>> Is it an USB-issue (I already changed through all my USB-cables)?
>>> Have you tried with another driver? Pxlmono seems to be the recommended
>>> for your printer but true is that there are many available...
>>> http://www.openprinting.org/printer/Samsung/Samsung-ML-2150
>>> Greetings,
>>> --
>>> Camaleón
>> I will second this.  Try one of the other drivers available.  I
>> recently had this problem with an HP laser printer and had to change
>> from the CUPS+gutenprint to an HPLIP driver to get rid of the problem
>> (garbage printed and then the printer locking up, requiring a power
>> down.)
> strange but probably true
> I changed to gutenprint and printed several jobs in a row

must be something else.

now that I watched the issue for several days I come to the conclusion,
that it must be something with the USB stack.

The printer gives me one good printout whenever it is switched on or
unplugged from USB and replugged.
All subsequent printouts are garbage.
The type of garbage depends on the driver (tried several  PCL drivers)

tried it on different computers - same result.
common to those computers is: they run kernel 3.0.0-1-amd64

tnx for your help
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


Reply to: