[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SOLVED: can't get GRUB to install from netinstall cd's - THANKS!

Thanks so much to all those who took the time to respond to my anguished
plea for help trying to get Wheezy installed from a netinstall cd image
but the install kept failing to install GRUB. Evidently, this is a common
problem with netinstall images.

Thanks to Pelle Carlson,rlharris, David Christensen, Brian, and Camaleón.

Pelle Carlson confirmed for me that at least one of the weekly builds was
working (Aug22) so that I understood I needed to look more closely at 
something I was (or wasn't) doing rather than keep trying different

rlharris recommended doing a minimal install first, which is pretty much
what I wound up doing.

David Christensen also recommended using the simplest installer. David- I
mostly agree with you about having a small seperate boot partition and may
do that again in the future, but for now it seemed simpler to go with the
recommended "all files in the same partition".

Brian (ad44) who said:
> "in-target: E: Package 'grub-pc' has no installation candidate."
> "grub-installer: info: Calling 'apt-install grub-pc' failed"

"This is [a problem]. Returning to the 'Install the base system' step is
an option."

This is probably the key piece of info that I needed to hear. When I would
get to the error message "Debootstrap Warning. WARNING: Failure while
configuring base packages. This will be attempted up to five times" I had
been just ignoring it and giving up. I figured that if it didn't work the
first time it probably wasn't going to work doing it more times. Well, I
was wrong. Forcing it to try again (at this step) in fact did accomplish
loading Grub. It may have helped also that I took other peoples advice and
was in the simplest install menu (many things automated)- not sure.

Brian- also said "Unless there is an overwhelming need to get to testing
from a testing installer you can do a Squeeze install of the base system,
change /etc/apt/sources.list to point to Wheezy and 'apt-get

This was an option that I had already tried. AFAIK when you install
Squeeze then full-upgrade to Wheezy you are only updating the packages-
NOT the kernel. I needed the 3.0 kernel to fix the problem with my
Thinkpad T520 laptop not resuming from sleep properly and to get other
features (like TRIM for my SSD). I had also for weeks tried compiling a
3.0 Squeeze kernel to no avail as well- choosing kernel compile options is
tricky (for a beginner). At this date, you can't get a 3.0 kernel any way
other than a netinstall or compiling your own kernel (AFAIK).

Camaleón said: "For GRUB2, you can leave it uninstalled and boot the
installed system from a LiveCD/LiveUSB or SGD. Once you're in, install
GRUB2 as usual." I had tried this with no luck. For a beginner, installing
Grub manually is actually quite complex- I tried several different
approaches. Do a search on "grub rescue>" and see how many problems and
solutions are out there...

So, the netinstall image finally installed Grub, but left me with a very
minimal system. I had to learn to manually configure the network and
install the desktop. But I was able to do these things and I am glad I
did- this way I can start with a fresh un-bloated system and add packages
as I want them.

Again, thanks to all.
Keith Ostertag

Reply to: