[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: atfptd in squeeze won't do anything

On 24/08/11 01:24, Isaac Freeman wrote:
I have been beating my head against the wall on this for a day and a
half. I just installed atftpd (0.7.dfsg-9.1) on Squeeze. When I first
installed it, it wouldn't take connections through the default inetd
stuff. So I tried editing /etc/default/atftpd and setting
USE_INETD=false and running it as a daemon. Still nothing. So I tried
manually running /usr/sbin/atftpd, and no matter what options I give it
(including none) it just prints the usage and exits, unless I specify
--daemon and/or --no-fork in which case it just exits with an exit code
0 and there is no process running or anything listening on that port.

Please, any ideas, reports or similar (or even different) behavior, or
any thing else would be greatly appreciated. This is driving me crazy.
And I can't seem to find any recent howtos on the subject, they all seem
to be several years old, or they say basically "apt-get it, and it
should work".

Also, I tried getting tftpd-hpa working too with similar problems, but I
haven't done as extensive of troubleshooting on that.

Isaac Freeman - Systems Administrator
IBM Information Protection Services

I've only ever used tftp for pxe servers - deprecated with gpxe (http is much faster and simpler) - if that's what you want to use tftp for you'll find tftpd-hpa much simpler to configure.

What permissions do you have on the directory being served??

Have you set up:-

If you can tell me a little more about what you want to use tftp for more it may be helpful.


"Folks, it's time to evolve. That's why we're troubled. You know why our institutions are failing us, the church, the state, everything's failing? It's because, um – they're no longer relevant. We're supposed to keep evolving. Evolution did not end with us growing opposable thumbs. You do know that, right? There's another 90 percent of our brains that we have to illuminate."
— Bill Hicks

Reply to: