[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: atfptd in squeeze won't do anything

On Tue, 23 Aug 2011 11:24:22 -0400, Isaac Freeman wrote:

> I have been beating my head against the wall on this for a day and a
> half. I just installed atftpd (0.7.dfsg-9.1) on Squeeze. When I first
> installed it, it wouldn't take connections through the default inetd
> stuff. So I tried editing /etc/default/atftpd and setting
> USE_INETD=false and running it as a daemon. Still nothing. So I tried
> manually running /usr/sbin/atftpd, and no matter what options I give it
> (including none) it just prints the usage and exits, unless I specify
> --daemon and/or --no-fork in which case it just exits with an exit code
> 0 and there is no process running or anything listening on that port.
> Please, any ideas, reports or similar (or even different) behavior, or
> any thing else would be greatly appreciated. This is driving me crazy.
> And I can't seem to find any recent howtos on the subject, they all seem
> to be several years old, or they say basically "apt-get it, and it
> should work".
> Also, I tried getting tftpd-hpa working too with similar problems, but I
> haven't done as extensive of troubleshooting on that.

Well, I've never used such service but I would:

- Read the docs ("/usr/share/doc/atftpd/"), maybe it requires some tweaks 
to put it to work

- Review the logs, once you start the service and try to make a 
connection from a client machine

- Look into Debian BTS, maybe there is a bug on that concrete package 
that can be hitting you:


- And finally, google for any recent tutorial/howto on the matter:




Reply to: