[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Partition not mounted. Was Transplanting old System to New Drive

On Tue, 16 Aug 2011 10:21:05 -0500, Martin McCormick wrote:

> You write:
>> I'm not sure in what stage of the migration are you right now (I did
>> not follow the full thread), but have you tried to boot from a LiveCD
>> and work from there?
> 	I have been avoiding that. I don't know if this is
> peculiar to Dell mother boards, but every so often, my CMOS boot order
> sequence gets reset to something that always puts the hard drive ahead
> of the CDROM. Since the hard drive boots, game over. As a computer user
> who is blind, most mother boards have no alternative method for
> configuring the CMOS than eyeballs facing a screen.


Okay, I got it, let's discard that option then :-)

> 	Getting back to the issue at hand, I am actually one step away
> from being where I need to be. The image on /dev/hdb1 contains some
> sort of flag that was copied from the image of /dev/hda1 which is, in
> fact mounted. 

Let's recap. What you now want is to alter/edit/delete one of your target 
partitions, right?

What does command "mount" say?

AFAIK, the mounted status for a volume is not hard-recorded anythere on 
the file system that is being mounted, but, hum... I would not put my 
hand in the fire for that statement >:-?

> If I could do something to /dev/hdb1 to clear that flag, fdisk will let
> me resize that partition to the larger size or at least it lets one
> change the last cylinder to then allow resize2fs to work. That's really
> all that is left.

Have you tried with "gparted" or "cfdisk"? The first it's a GUI based 
tool which usually manages very well these situations and the latter is a 
more convenient tool (text based) when it comes to manage partitions from 
command line.



Reply to: