[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unidentified subject! (wireless installation problem)



Sorry, you're right that was the wired interface, I must have cut n pasted the 
wrong line, my wireless is:

0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] 
Network Connection (rev 02)


I'm sorry to hear the installer only supports WEP. That would make it hard for 
anyone without a wired connection.

I did look at the tty with the logging info I don't remember seeing anything 
obvious. I'll try again though.

What seems strange to me is there are two completely unprotected/unencrypted 
wireless networks that I can connect to and browse the net with, but they are 
not detected by the installer. When I manually specify my protected network in 
the installer, it just errors out saying it can't reach it, not that its a level 
of encryption not supported, or other specific error. I'll try manually 
specifying one of the unprotected networks next time.

I tried the install again after my original post before getting your reply, and 
the wireless light blinks a lot after the installer finds the iwl firmware deb 
file. Originally I said it only blinked when finding the firmware, but I must 
have just not noticed it. When I specifically watched for it, I see it blinks 
like mad when the installer says it's trying to detect wireless networks. So it 
really seems like its trying.....

Thanks.


----- Original Message ----
From: Camaleón <noelamac@gmail.com>
To: debian-user@lists.debian.org
Sent: Fri, August 12, 2011 12:39:47 PM
Subject: Re: Unidentified subject!

On Thu, 11 Aug 2011 06:13:12 -0700, gnubayonne-debian451@yahoo.com wrote:

> I'm trying to do a fresh install of 6.0.2.1, but there is a glitch
> bringing up the wireless network on my 1420N Inspiron laptop. It uses
> the iwl3945 driver:
> 
> 09:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5906M Fast
> Ethernet PCI Express (rev 02)

That's the wired adapter not the wireless one, right? :-?

If you can use this adapter I would definitely go with it. Wifi can be 
flaky for a full installation.

> I boot with with the first i386 CD and it goes through the installer
> until it asks if you need to load firmware from removable storage. At
> first I just put the actually ucode files on a USB stick, but it didn't
> like that. But after putting the iwl firmware deb file, it now installs
> the modules. At the command-line, I can see the iwl3945 module running.
> I then select the wireless interface in the next screen where you pick
> what network interface to use, however it can't see any wireless
> networks. I try the manual setup, but it still doesn't see the network.
> In addition to my protected network some of my neighbors have
> unprotected networks and it can't see them either.

IIRC, the installer only allows WEP encryption, so ensure your AP is 
configured as such if you still want to proceed in that way...

> When its loading the modules from the usb stick, I see the wireless LED
> on my laptop flash a few times, but after that it stays off.
> 
> I'm not sure what else i can do with it, the install CD doesn't seem to
> have ifconfig or iwconfig. But with lspci I see the device and the
> correct iwl modules are running and I see the iwl ucode files in
> /usr/lib/firmware.

(...)

Installation is a complex and delicated task I always take very seriously 
and so try to avoid anything that can complicate things in this stage
(like using a wifi card :-P).

Anyway, to see what's going within the installer on you can jump to tty4 
(if not 4 try with another, I never remember the number).

Greetings,

-- 
Camaleón


-- 
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: pan.2011.08.12.16.39.47@gmail.com">http://lists.debian.org/pan.2011.08.12.16.39.47@gmail.com


Reply to: