[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: C compiler cannot create executables no good google answers

Harry Putnam <reader@newsguy.com> writes:

> lee <lee@yun.yagibdah.de> writes:
>>> I got past that now... apparently finally got whatever it was
>>> installed.  But now ./configure complains about X libraries:
>>>    error: You seem to be running X, but no X development libraries
>>>    were found.  You should install the relevant development files for
>>>    X and for the toolkit you want, such as Gtk+, Lesstif or Motif.
>>>    Also make sure you have development files for image handling, i.e.
>>>    tiff, gif, jpeg, png and xpm.
>>> Do you know which packages might be needed?
>> Not yet; give me some more time and I'll try to compile emacs24 and let
>> you know what I find out ...
> OK, thanks for the effort.

You're welcome :) It might be nice to try out the most recent version of
emacs ...  I needed to install libgif-dev for configure to
finish.  Now it's compiling ... and seems to have finished without
errors :)  Yes, and I can run it just fine.  It seems to have trouble
finding some packages required from my ~/.emacs.  That's probably
because I didn't install it before trying.

What I have installed is lesstif2 and libgtk2.0-dev.  You can try
installing libgtk2.0-dev or libgtk-3-dev or libmotiv-dev.

Reply to: