[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: aptitude/apt-get hangs during update (plus) on IPv6

On Tue, 31 May 2011 09:50:48 -0400, Jeffrey B. Green wrote:

> I'm seeing if there is an alternate answer here before filing a bug. (I
> believe) All of the servers here that have IPv6 configured hang while
> attempting an update on security.debian.org. If I turn off IPv6 by
> deconfiguring the IPv6 address, then the update goes through fine.
> When I check with tcpdump to be sure the firewall isn't the culprit, I
> find that all of the packets that reach the firewall also make it to the
> server and a conversation of 20-22 packets occurs (20 on one server, 22
> on a different one). [If anyone wants to provide me with a state
> transition diagram, or even a description, for the protocol aptitude
> follows in doing the update, then I'd be happy to track down where
> exactly in the process it hangs.] I can go back and forth with enabling
> and disabling IPv6, and IPv4 always seems to work (just tried it with
> one server).

I think this also happened to me just a few days ago. I couldn't reach 
any of the security servers and suspected it was because apt tried to 
reach the ipv6 server which, thanks to my ISP (grrr!), is something I 
still can't do :-/

How I solved it? Retrying the update command until I finally got the ipv4 
server address as response }:-)
> Sooooo, if anyone knows what going on here or whether this looks like an
> official bug, then let me know.

There is a wishlist bug report to enable/disable ipv6 just for apt, which 
I think it should be something nice to have at least for this ipv4/ipv6 
transtitional period that is coming...

please give apt.conf.d option to disable ipv6



Reply to: