[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to get Bell Canada 3G USB network up?

Christian Jaeger <chrjae <at> gmail.com> writes:

> Another update in my quest to get that UMTS modem work properly:
> Bell technical support told me that I should run a firmware upgrade on
> the stick (and gave me a link to the exact file). Of course that's a
> windows .exe. I tried to run it in a second hand computer store that
> let me plug in my Bell stick, but it didn't work, probably because I
> didn't install the driver beforehand, the installer and upgrade
> utility conflicted with each other. So I gave up for some time.
> Now I've finally gotten an own computer with Windows (XP), so I
> installed the modem first, then ran the firmware upgrade. Both worked
> without problems. Also, on Windows the modem doesn't seem to exhibit
> that disconnect problem. Then I tried again on Debian, and nothing
> changed, disconnection on first try. Duh.
> So, if anyone knows what's left that I could try (well I'll try
> contacting some network manager people), or knows which USB UMTS modem
> works on Debian in Canada (with Bell), please tell.
> Thanks
> Christian.
Reading your first post on this issue I see that you remove the option module in 
favor of usbserial. That advice is all over the net. Are you still doing that ?
I think it is -basically- wrong: 'option' is the specialised driver for this and 
many other 3g modems. 'usbserial' is -only- a generic driver on which you can 
fall back if-all-else-fails. ( I am citing the author of usbserial )

I suggest that you go back to the beginning, probably a clean, fresh install of 
Squeeze, stick the modem in and see what happens. Or a live cd, or, ..

In Squeeze usbmodeswitch is standard.
Then the option module should grab the modem.
The module creates /dev/ttyUSB* 

After that the dialling: that is specific for your provider.

HTH, --Jasper.

Reply to: