[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to get Bell Canada 3G USB network up?

> Reading your first post on this issue I see that you remove the option module in
> favor of usbserial. That advice is all over the net. Are you still doing that ?
> I think it is -basically- wrong: 'option' is the specialised driver for this and
> many other 3g modems. 'usbserial' is -only- a generic driver on which you can
> fall back if-all-else-fails. ( I am citing the author of usbserial )

I think I'm only removing the modules so they can be reloaded
afterwards, i.e. to reset their state. At least I think it worked
equally both with reloading option afterwards and without.

Now, option is actually loaded when I connect; and, interestingly it's
not at the top of lsmod output, and, as I realize now, my own
initialization scripts are not even called anymore as it seems. I'm
quite confused; on 2011-03-20
/lib/udev/rules.d/40-usb_modeswitch.rules was changed to a version
that doesn't call my hook. I don't have any record that I did this
myself, and don't remember anything about it, I can only conclude that
some Debian package upgrade did it. Sigh. (Ok I know that /lib isn't
/etc, but then why are those files in /lib? Or do /etc/udev/ files
override those in /lib/udev?)

It seems the option module is actually being used by network manager
(directly or indirectly), since lsmod shows its use count going up to
2 when I'm connecting, and dropping back to 0 when I unplug the stick.

option                 12918  2
usb_wwan                6147  1 option
usbserial              21120  7 option,usb_wwan

> I suggest that you go back to the beginning, probably a clean, fresh install of
> Squeeze, stick the modem in and see what happens. Or a live cd, or, ..

I've just booted from a current Ubuntu live image. The exact same
thing happens once it connects: 20 seconds after connection is up it
is being dropped again. (This happened 2 times.) The difference to my
Debian setup is that about 4 further times I tried to up the
connection, it didn't even enter up state; network manager would just
show "connected", but the stick would still blink its LED instead of
going to light it up constantly as it would when connected, then a
couple seconds later network manager would say "disconnected"; after
that no connection attempt succeeds, I unplug+replug the stick to try
again. So it's just worse...

> In Squeeze usbmodeswitch is standard.

Yes, but it didn't work reliably in Ubuntu back when I tried a year
ago, and not at all in Squeeze (testing back then), which led me to
write my own switching scripts.

When I tried it on the newer Ubuntu today, watching syslog and nm
popup messages, it seems usbmode switching is reliable (and fast, in
~2 seconds), but as mentioned it then fails to connect at all in the
majority of cases. Actually I think that's exactly what happened a
year ago, and I probably just mis-concluded that usb mode switching
wasn't reliable on Ubuntu, where in fact the switching itself seems to
work fine, but somehow in about 2/3 of cases leaves it in a state that
doesn't allow it to connect.

How do you connect, using nm or something else?

Well I'm also going to try a Debian live image, to confirm whether
withoug my own scripts it works the same.


Reply to: