[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to stop a message which requires the Enter key

Hash: SHA1

Arno Schuring wrote:

> I suspect the reason is that you're using encrypted swap partitions,


> yet the hibernate package automatically assumes the first swap
> partition is also the resume partition. Since that partition is not
> available at wakeup (it can't be - the encryption key for swap
> partitions is autogenerated at every boot), it just sits there waiting.

Correct again.
> Please check if you have a line RESUME= in
> either /etc/initramfs-tools/initramfs.conf

In my Lenny box there is no resume line in that file.

> or /etc/initramfs-tools/initramfs.conf.d/* and remove (or comment) it.

In this directory there is one file named "resume" which has only one line:


I commented it out.

> Then regenerate your initramfs (update-initramfs -u)

Running this command generated the following response:

update-initramfs: Generating /boot/initrd.img-2.6.26-2-686
cryptsetup: WARNING: target VG1-swap_crypt has a random key, skipped

I then rebooted.

> and see if this
> solves your problem.

Unfortunately it did not.

I then simply renamed the resume file to resumeX, ran the
update-initramfs -u command and rebooted again.  The problem was still
not solved.

Next I changed the resume file to refer to a unencrypted partition not
part of VG1:


An then ran once more update-initramfs -u, which this time returned

cryptsetup: WARNING: found more than one resume device candidate:
cryptsetup: WARNING: target VG1-swap_crypt has a random key, skipped

And rebooted once more -- but still have the problem.

Finally, now that I know the path of the resume file I change the line
in the file back to the original, ran update-initramfs -u, and rebooted.

When the "could not stat" message was received, this time I did what was
asked: enter the path of the resume file /etc/initramfs-tools/conf.d and
hit the "Enter" key.  At that point the "could not stat" message was
received again; but pushing the "Enter" key without any path entered
continued the boot as before.

This phenomenon did not happen before I installed the hibernate package.
 It is quite possible however that a warning message the same or
conveying the same message as

cryptsetup: WARNING: target VG1-swap_crypt has a random key, skipped

appeared but did not stop the boot process.  In that case the message
would scroll off the screen too quickly for me to see it.  Stopping the
boot process until the "Enter" key was hit is the one difference now
occurring after I unsuccessfully tried hibernate.  So I conclude that
using hibernate changed something somewhere to cause this particular
stop in the boot process which did not happen before.

> If the above holds true, you might want to file a wishlist bug against
> hibernate to not consider encrypted swap partitions as viable resume
> partitions.

Not a bad idea if I knew how this bug got there and how to fix it.

Ken Heard
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Reply to: