[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#611380: openssh-client: sftp's put -r fails with "Unable to canonicalise path"


 I was wondering if there was a scheduled fix for this or if I was possibly using 
 sftp incorrectly in Debian Squeeze. 
 I am attempting to upload files onto my webserver using sftp.  As far as I can 
 tell from reading the man pages and searching online, the correct syntax once 
 connected via sftp is:
 put -r * 
 I have tried that along with just trying to move one directory at a time (    
 eg.  put -r content/     )  and I keep getting the same above error message 
 (canonicalise).   I tried it on two different web servers to maybe rule out the 
 possibility of the problem being in the configuration on the ssh server side. 
 I tested this on a go-daddy hosting web account and a debian Squeeze file 
 server  that I have at  home.  I got the same behavior so I am thinking the problem 
 is with the openssh-client on my Squeeze laptop.
 I am relatively new at this and this seems like basic functionality expected out 
 of an sftp program, so I am betting that I am doing something wrong.  Any help 
 would be much appreciated.  

Reply to: