[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dovecot Problems on Sid

On Saturday 10 Iyar 5771 15:26:42 debian-user-digest-request@lists.debian.org wrote:

> > Updating to the Sid version was a catastrophe--flagged all kinds of

> > superseded syntax warning which were flagged as errors when I tried to

> > edit them into the conf file. Commented out, got listening errors for

> > various 9## ports.

> >

> > 

> >

> > So I downgraded to the testing version and used a backed up conf file.

> >

> > 

> >

> > No startup errors, dmesg, nothing, but "localhost refuses connection"

> > when trying to access imap on the system. From outside, "server not

> > found."

> >

> > 

> >

> > Nothing like this is listed in the bugs. Has anyone encountered such

> > problems, fix them?


> I have just run an update and ended up with no working dovecot. Someone is

> brainless - but definitely not me!


> I've tried the quick config guide from dovecot webpage, but still nothing.

> I have one process running and no imap/pop3 ports open


> so is there a human usable step by step config guide, for a simple setup

> with pam and local maildir?

Unfortunately, the maintainers changed the configurations to the "more modern/recent" conf.d directory script system without providing any script for transition and NO WARNING for apt-listchanges. To tell us to avoid "unstable" is no excuse, especially for the lack of notice.

The recourse is to

1. Make a copy of your current conf for reference.

2. reinstall, taking ALL the new package configs.

3. Then go to the conf.d scripts and replace items from your original conf.

10-mail.conf and 10-master.conf are the two which get a couple of things from your original. They are decently documented in place and the items look quite like the former versions.

If you are getting errors due to port addresses, then the imap and pop3 configs have place to replace those. Working defaults are shown in your original--dont ask why these were changed.

(Make sure that the old conf file is no longer in /etc/dovecot/ since the old and new are obviously incompatable.)

Reply to: