[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [OT] compiled kernels do not boot

Stephen Powell wrote:
On Fri, 25 Mar 2011 16:19:11 -0400 (EDT), Hugo Vanwoerkom wrote:
I have tried 3 self-compiled kernels and they do not boot. They compile w/o errors.

They are compiled with 'make-kpkg --revision 1 --append-to-version -ck2 --initrd kernel_image'. This is with an uptodate Sid.

I have looked at the initrd files with cpio and I see nothing wrong: the 'init' file is there as it should be, etc. But what to look for?

I use legacy-grub and that just sits there with 'boot' as the last command, forever.

Does anybody have any suggestions as to what to try next?

I have used make-kpkg many times, but not in the last 5 months, and this has never happened to me.

The first thing I would try is to configure a custom kernel exactly
like a stock Debian kernel.  Assuming a stock Debian kernel boots
successfully, and assuming that you are using the Debian kernel source
which corresponds to the stock Debian kernel, that will tell you if
there's something wrong with your kernel configuration or if there's
something wrong with the logistics of your compilation and installation.

That's the first thing I did: stock Debian kernel. And it does not boot.

If I were to hazzard a guess, I would guess that you don't have a
feature enabled that your hardware needs.  But that's just a guess.

But the Debian kernel image boots, so the compiled stock kernel ought to also. My guess is that I have to change the make-kpkg scripts somehow. Since the last time I ran make-kpkg successfully I have changed motherboards.

The following resource may be helpful to you:


Reply to: