[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to connect to CUPS server after upgrading to Squeeze

On Friday, 04 March 2011 10:35:06 +0000,
Nuno Magalhães wrote:

> Hi,

Hi, Nuno.

> > After upgrading to Squeeze, I tried to do a test print from a client
> > with Lenny and I could not connect to server. From what I see, the
> > server is up:
> >
> > sirius:~# netstat -puta

> Nice mnemonics ;)

And that I'm not using it to verify connections of tftp ;)

> Have you tried localhost:631? Have you been fiddling with a firewall
> (or has it been updated)?

> I've recently dist-upgraded on Sid and :631 is working fine.

Roger, I forgot to copy some of the lines of the netstat output. Here's
the output with grep:

sirius:/etc/cups# netstat -puta | grep ipp
tcp        0      0 sirius.freesoftware:ipp *:*                     LISTEN      21266/cupsd
tcp        0      0 localhost:ipp           *:*                     LISTEN      21266/cupsd
tcp6       0      0 ip6-localhost:ipp       [::]:*                  LISTEN      21266/cupsd
udp        0      0 *:ipp                   *:*                                 21266/cupsd

I tried to connect to localhost:631 with links2 on the server host and I
get the CUPS interface. I also connect seamlessly to sirius:631 from
Iceweasel on the machine with KDE where I had given the message that I
mentioned earlier. But if I try to connect sirius.freesoftware:631 or
printer.freesoftware:631, I get:

400 Bad Request.

This looks like a bug [1] and it was also reported in Debian for some
time [2].

Thanks for your replies.


[1] https://bugs.launchpad.net/ubuntu/+source/cups/+bug/516018
[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=525910
Fingerprint: BFB3 08D6 B4D1 31B2 72B9  29CE 6696 BF1B 14E6 1D37
Powered by Debian GNU/Linux Lenny - Linux user #188.598

Attachment: signature.asc
Description: Digital signature

Reply to: