[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

gnome-settings-daemon error


I'm getting an error message from the gnome-settings-daemon when I log in, and the desktop takes more time than usual to appear.

Running Lenny 5.0 with Gnome 2.22.3

The error message is:

"There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The last error message was:

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

GNOME will still try to restart the Settings Daemon next time you log in."

In the .xsession-errors there's a part where to warnings that could be relevant are shown:

Window manager warning: Failed to read saved session file /home/juan/.metacity/sessions/default0.ms: Failed to open file '/home/juan/.metacity/sessions/default0.ms': No such file or directory


** (gnome-settings-daemon:7677): WARNING **: Failed to open file '/etc/gnome/config/General.ad': No such file or directory

If I run 'gnome-settings-daemon --debug --no-daemon' I get the following:

** (gnome-settings-daemon:9367): WARNING **: Failed to acquire org.gnome.SettingsDaemon

** (gnome-settings-daemon:9367): WARNING **: Could not acquire name
** (gnome-settings-daemon:9367): DEBUG: SettingsDaemon finished

There's a bug report that speaks of this but there's no conclusion yet about it: bug #473409:�http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=473409

Anyone is having the same issue �/ knows the way to solve it?

Thanks in advance,

Reply to: