[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: All hung up over netatalk

On 01/-10/-28163 11:59 AM, Tom H wrote:
On Fri, Nov 12, 2010 at 2:45 PM, Gary Roach<gary719_list1@verizon.net>  wrote:
On 01/-10/-28163 11:59 AM, Tom H wrote:
On Thu, Nov 11, 2010 at 7:29 PM, Gary Roach<gary719_list1@verizon.net>

I have a dual boot Toshiba Qosmio "laptop?" that I am upgrading from
to Squeeze. Everything worked fine (Using Aptitude) until the
of netatalk started; a program that I really don't need. I get:

hostname: Unknown host

First /etc/hostname is filled in. When I attempt to reinstall I get the
type of error and the process aborts. When I try to remove or purge the
application I get the same result. An of course, Aptitude won't finish
upgrade installation because of this error. I get essentially the same
result with dpkg. How can I get out of this mess. Help!

Take a look at the netatalk maintainer scripts in "/var/lib/dpkg/info"
to see why they are failing.

The /bin/hostname is not returning the hostname. Is this a bug?
Check "/etc/hostname" and "/etc/init.d/hostname.sh" and whether there
is an Sxxhostname.sh in "/etc/rcS.d".
All of the above were true. I have meticulously removed netatalk from the system a piece at a time using the information in /var/lib/dpkg/info. The problem now seems to be the Aptitude database. Netatalk is marked with a Cp code and won't do anything until it tries to process netatalk. Of course, it immediately errors out. How can I change the Aptitude database manually. Running aptitude keep-all just generates the same type of errors as everything else and doesn't do nothing. I would love to reinstall Aptitude at this point but that doesn't work either.

Gary R.

Reply to: