[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: All hung up over netatalk

On Fri, Nov 12, 2010 at 2:45 PM, Gary Roach <gary719_list1@verizon.net> wrote:
> On 01/-10/-28163 11:59 AM, Tom H wrote:
>> On Thu, Nov 11, 2010 at 7:29 PM, Gary Roach<gary719_list1@verizon.net>
>>  wrote:
>>> I have a dual boot Toshiba Qosmio "laptop?" that I am upgrading from
>>> Lenny
>>> to Squeeze. Everything worked fine (Using Aptitude) until the
>>> installation
>>> of netatalk started; a program that I really don't need. I get:
>>> hostname: Unknown host
>>> First /etc/hostname is filled in. When I attempt to reinstall I get the
>>> same
>>> type of error and the process aborts. When I try to remove or purge the
>>> application I get the same result. An of course, Aptitude won't finish
>>> the
>>> upgrade installation because of this error. I get essentially the same
>>> result with dpkg. How can I get out of this mess. Help!
>> Take a look at the netatalk maintainer scripts in "/var/lib/dpkg/info"
>> to see why they are failing.
> The /bin/hostname is not returning the hostname. Is this a bug?

Check "/etc/hostname" and "/etc/init.d/hostname.sh" and whether there
is an Sxxhostname.sh in "/etc/rcS.d".

Reply to: